cars

allpar, the Chrysler - Dodge - Plymouth - Jeep site

Chrysler automatic transmission repair: solenoid pack rebuilding

solenoid pack repairAnybody who ever stood on a street corner in the early nineties waiting for pedestrian signals to change knows what the infamous Chrysler A-604 (a/k/a 41TE) solenoid pack sounds like. Bzzzz-tick!

Over time, this sound became so common that it was at one point abnormal not to hear it. Still, as time went on, Chrysler decided to do something about this and started making these solenoid packs with better sound shielding. By the time 1996 came around, you had to hold an ear right up next to the transmission to hear it.

Why am I waxing nostalgic about the annoying buzzing sounds the older A604 solenoid packs make? Bear with me a moment, if you will. In 2008, I finally found myself the luxury vehicle I had always wanted - an Imperial, 1992 vintage, in Surrey, BC. The first thing I looked at when evaluating the car was the state of the transmission fluid. What I found was some very dirty ATF+3 that fortunately did not smell burned. Reasoning that all the car needed was fresh transmission fluid, I took a chance on the car and bought it.

The symptoms appear: hard shifts, slipping

The drive home through the mountains revealed issues. The car shifted pretty well, but would slam in and out of overdrive in the mountains when transitioning between downhill and uphill climbs. Most other shifts were noticeable enough that I knew I needed to address the situation immediately when I got home. And so I did. Going by the guide found elsewhere on this site, I replaced the transmission filter and flushed out all the old, dirty ATF+3 in favor of new ATF+4. Observing that the old fluid was visibly full of metallic particles, and the magnet in the pan had a big metal afro thing going on, I realized that I was probably not out of the woods yet. However, three of the pan bolts were stripped, hinting that the pan had been off before for service. There was still hope.

With the new fluid in, the transmission shift quality was vastly improved, but not all the way better. I quickly began to notice it still had minor issues. When the fluid was cold, the transmission would ever so slightly hesitate on its first few 1-2 and 2-1 shifts of the day. That first winter, it would slip at stop signs. And so, I did another fluid and filter change once spring came calling again, opting for just a pan drop rather than a full flush. I discovered almost as much material on the pan magnet as I had seen the first time I did the job. Clearly, my initial flush didn't get all the debris circulating through the transmission. I went out and found an updated TCM, part number 4796124, and dropped that in, too.

That's where my transmission stopped making progress, and led me on the path to this article. The new fluid and TCM did nothing more for the early morning shifting quirks my A604 was still exhibiting. I sat down to think about this... what could be causing the car to shift like new with the fluid at operating temperature, and yet be so reluctant on its first 1-2 of the day? Couldn't be the speed sensors, I had just cleaned them of their debris. It had to be a low fluid pressure situation. Either the seals were leaky, the pump was lazy, the cooler was blocked, the hoses were kinked, or something else was to blame.

Further troubleshooting and the solution

I began to rule things out. To eliminate bad seals, I added Lucas transmission fix, which has been known to help A604's with bad seals. This did next to nothing. Initially, it would seem like it was helping, and then the unit would go right back to the way it was before. I checked the cooler hoses - not kinked. I stuck the return hose in a clear bottle and watched as I ran the engine - nice flow. I had the CVI values scanned - well in spec. No transmission trouble codes. What else could it be? Was there anything else I could try without having the unit yanked and rebuilt?

Then one day, I went for a drive. I normally drive with the automatic temperature control (ATC) system on all the time, so I rarely use the windows. But on this lovely day, it was so nice outside I wanted to enjoy it. I buzzed the windows down, shut off the ATC, and shifted into reverse. BRAAAACK! I sat there for a moment, stunned. Was that my solenoid pack?

I shifted into park, then back to reverse. Yes, that was indeed my solenoid pack. I knew that the solenoid pack had little filter screens in it to help keep the nasty stuff in the fluid from going any further into the transmission, but like many people I had been told that these rarely need replacement and did not really contain any serviceable parts. It was something I just hadn't considered as part of the problem.

Master Tech Chris Taurman wrote, some years ago: “Do not take solenoid packs apart. This alters the calibration of the unit! If the filters are plugged up, replace it!” We leave the choice up to you. This article is useful either way in showing how to remove and replace solenoid packs.

So, we finally get to the point of this article. I had two choices - either I could replace the pack or get inside it and find out why it sounded like an Uzi. Replacing it would be expensive, but would get me the newer, quieter style pack. On the other hand, if I could just find those little filter screens brand new by themselves, maybe I could save some money and have some fun by taking the thing apart and seeing how it worked. I hit eBay, looking for the filter screens. I knew that they could be cleaned, but reasoned that new screens were probably an even better idea.

That's when I found this:

solenoid pack repair kit K49902

Yes indeed, I found a rebuild kit for the A604/A606 (41TE/42LE) solenoid pack. There were two varieties - late 80s and early 90s, and 2000+ for the newer vehicles out there. Since I was rebuilding one from a 1992 Imperial, I bought the one above. Let me show you what was inside the bag.

repair kit parts

Two gaskets for the pack mounting surface and separator plate, eight little filter screens, two gaskets for the internal parts, three rubber clapper valve seals, three new clapper valve springs, and a new orange gasket for the pack connector. [Note: Marcos wrote that the “clapper valves” are the pressure switches, and Jeremy later wrote that, when the valves open, oil pressure pushes these and forces the brass plugs up to the metal rings to be grounded.]

Installing the solenoid pack rebuild kit

Now, I'll show you just how to do the job. This only applies to the A604 and 41TE; those of you with an A606/42LE will have to take extra steps to remove your valve body to gain access to your solenoid pack. The rebuilding process should be similar once you get to it, however.

A604

Here, I've moved my radiator overflow tank and cruise control servo out of the way for better access. My solenoid pack has already been disconnected - you will need an 8mm nut driver or socket wrench to do that. As you can see, I've already begun cleaning around the area.

And I need to stress this right now - the A604 likes cleanliness as much as a hospital surgeon does. You do not want any kind of dirt getting down into the transmission case when the pack comes off, and there are lots of places where that dirt can collect, both in front of and behind the solenoid pack. Clean, clean, clean around this area. Clean the hoses, the wires, the mounting brackets, and anything else immediately above the pack to make sure nothing goes awry when the pack comes off. When you're done, clean it all again. Me, I used Brakleen on the case followed by several sprays from the hose. I repeated this process several times, wiping things off with shop towels as I went. The above shot was taken in between cleanings.

Once everything has had a chance to dry, remove the input speed sensor, indicated by the red arrow. You need a 1" socket, a deep one, to do it. Mine came out of there with a generous coating of metal shavings, so I cleaned it off well. Then I cleaned inside the mounting hole. Then I pulled out the output speed sensor and cleaned that, too. There's really no such thing as "too clean" when you're dealing with an A604.

The yellow arrows indicate the long 10mm bolts that hold the pack to the transmission. It is the sheer length of these bolts that require you to remove the input speed sensor - they are very long indeed, and that middle one won't come out (or go back in) if the speed sensor is still there blocking it.

input speed sensor

Here's a close-up of the input speed sensor, freshly cleaned. It looks nothing like the output speed sensor, so there's not too much chance of confusing them.

valve body

The pack shouldn't put up too much of a fight when it comes off. The gaskets are all that holds it down, at least in my case. Once it does come off, be ready with the shop towels. Wipe any dirt and grime on the mounting surface away from the holes. Remove any bits of gasket that might be trying to hang around. If you think any dirt got down inside the holes, don't fool around - get the shop vac and get it out of there. Yes, you will make a mess of your shop vac that way, but it's better than making a mess of the valve body, no? The solenoid pack is downstream from the pump and filter. Any dirt that gets in these holes goes right into the valve body and then through the rest of the transmission before it gets back to the pan. You don't want that. Take no chances.

Once everything was clean, I found it easy to place a big wad of shop towels down on the mounting area, held down with the socket I used to remove the speed sensor, to keep the area clean while I worked on the pack. I reinstalled the speed sensor finger tight so I could easily remove it again later for solenoid pack re-installation. Though you can't easily tell by the above picture, the area the pack mounts to is sloped down toward the transmission. Any fluid will run down toward the curved lip, like that bead of transmission fluid you see above.

solenoid pack filter screens

Now that the pack is off, remove the separator plate and clean all surfaces. You want it clean enough to eat off of. Above, I've placed the pack so that you can see where all the little filter screens go, indicated by the red arrows. These are press fit in place. Remove them. We'll replace them after we get the rest of the pack apart and clean everything up. No sense replacing them without making sure we've cleaned everything we can reach.

Note that when you replace the screens, it is wise to do so with the little black plastic legs oriented so that they don't obstruct the flow of fluid. See those oblong holes in the bottom of the pack? They are there because some of the holes in the transmission and separator plate don't line up with the holes in the pack. The fluid has to follow the oblong channels in the pack - it's best not to block it in any way with those little filter legs. This should help the pump maintain proper fluid pressure through the transmission.

solenoid filters

A quick up close shot of the filters that came out of my solenoid pack. Three of them were particularly dirty, and I've arrowed them in red. Most of the others had metallic debris collected near the tips. You can indeed clean these filters and return them to the pack, but I had new ones so I tossed these old ones.

valve springs

To get the pack apart, there are six Torx T-25 screws to remove, held in place with green threadlocker. Once they come out, the pack will separate itself thanks to the pressure from the three valve springs you see arrowed in red in the above picture (one went AWOL as soon as it came apart).

In the case of my pack, I found that the above section - lid and middle - wanted to come off as a unit when the screws came out. Be very, very careful as you gently work the coils off the poles inside the pack. There will be some residual magnetism in the pack, and the four metal paddles you see indicated in green above will try to drag some tiny valve pieces out of the pack. Do not lose those. You need them.

Another thing to watch out for are the clapper valves. Indicated in red, they just sit there when the pack comes apart. Don't lose any part of those, either.

Before we go any further, take a look at the four poles in there, over which the coils sit. See the debris on them? That's all metallic residue. My solenoid pack was filthy with this stuff. Remember, these packs work using electromagnetism. If your fluid is allowed to get dirty enough, the solenoid pack will start acting like the pan magnet. That is why my solenoid pack was so noisy... it's been hoarding worn clutch material.

valve assembly

An extreme close-up of a valve assembly. See that little triangular metal valve piece? Normally, those sit all the way down in those holes on their beveled heads. I've posed this one so that you can see how they go down into the valves, because these are the very pieces that try to come out with the upper part of the assembly when it all comes apart. They are very small. Again... don't lose them.

A point of interest - the cover on the solenoid pack stated that taking the thing apart would alter the calibration of the unit. Replace instead of repair. I have to say... I don't get it. The parts affected by the rebuild kit are all the same... there's nothing to calibrate. The four little valve pieces like the one pictured above are identical - they interchange. The clapper valves interchange. The filters and gaskets interchange. Perhaps they are referring to the remaining valve pieces being held in by those brackets in the picture, I don't know. I didn't get that far into it.

transmission clapper valves

Now that everything's been taken apart and thoroughly cleaned, it's time to start using the new parts. Above, you see the major components of the clapper valves. The brass piece on the right is held inside the round metal valve on the left by one of those three springs that pushed the pack apart earlier. A little rubber seal separates the two parts.

clapper valves

Here, I've removed the rubber seal. It presses down into the valve with the lip facing the indentation, seen here with some red transmission fluid collected in it. Replacing these rubber pieces is fantastically easy. Pry the old ones out, push the new ones in, set the brass pieces back in the middle. Done.

automatic transmission fix

Now, we get even further into the pack. The cover has to come off, as you see above. In the top half of the picture are the resistors and contacts where the coils connect. It's not a bad idea to take your ohmmeter or multimeter and check the continuity on these coils while you're in here. You should observe about 1.8 ohms per coil. If you find one shorted, replace the whole pack - if you put it back in, it will probably fry the TCM and drop you into limp mode. Likewise, if you find one open, also replace the pack or you'll again get limp mode. But then, these problems should manifest themselves long before you actually get inside the pack. It's not that easy to do any real damage in here.

Note that the black piece has rubber gaskets around the edge on both sides. Replace them using the parts from the rebuild kit.

transmission repair

It's time to start putting things back together. In this shot, everything has been cleaned up and the unit is ready for reassembly. The four valve pieces indicated in blue are all in place and accounted for. The three clapper valves in red have been reassembled and set in place. Take the black piece, coils facing down, and gently work it down into place. Go slowly - the coils are socketed into the black piece, and it's easy to to knock them askew. If that happens, the metal bars below them - the ones the coils magnetize to activate the blue arrowed valves - will move out of place and aggravate you when you try to get them to go back where they belong.

automatic transmission valves

If you did it right, you should see the above view. Look down through the three clapper valve spring holes (red arrows) and make sure those valves are still in place. Then, take your new valve springs and set them inside the holes. They should go right down and nest inside the little brass pieces of the valves.

Time to put the cover back on. Gently set it in place on top of the pack. The springs will keep it from going all the way down, but that's okay for now. Using threadlocker on the six Torx screws - I used the blue stuff not having any green - press down on the cover, and get all six screws started. Then, tighten them down firmly. I could not find a torque spec for these screws, but I don't think it's necessary. As long as they're hand tight with a decent screwdriver, they shouldn't go anywhere. Especially with threadlocker.

solenoid pack repair

One last step remains at this point, unless you waited until now to put the new filter screens in. Replace the connector gasket with the new one from the rebuild kit. As you can see, my old one is in bad shape, with a large crack above the round bolt hole. I actually found transmission fluid in there once.

Now, there's only one thing left to do - put the pack back on the transmission, using the new gaskets supplied. Don't forget the separator plate, if you have one. Torque the mounting bolts down to 105 inch pounds, double checking the torque on all three before you reinstall the input speed sensor and reconnect the pack.

You are probably wondering by now what the result of all this work has been on my 1992 Imperial. Did it improve things? Yes. It did improve things, rather noticeably in fact. My pack is much quieter now, making the familiar bzzzz-tick it's supposed to make. No more machine guns under my hood.

But what about my shifting quirks? Has this experiment done anything to alleviate those? Well... yes and no. If the car has been sitting for days, those initial cold 1-2 shifts are still a little lazy. "Ho-hum, I guess I'd better shift now. I wanted to sleep in, but apparently the driver wants to go faster." However, if the car has not been sitting for days, has been used as recently as the day before, the cold start hesitation is gone. It's just a bit slow on the very first 1-2, but there's no major hesitation all the way to the post office like there used to be. The transmission used to bump shift when braking to a stop downhill at very low speeds. That's been improved too - it still does it, but not as often. I suspect this is more than likely due to the speed sensors re-accumulating metal shavings, however, rather than low fluid pressure.

Highway performance is both the same and different. This car with ATF+4 has always shifted like butter at highway speeds, and it still shifts like butter at operating temperature. But somehow, it feels different. Perhaps this is because the TCM now needs to re-adapt to a clean solenoid pack, I don't know.

I'm still not out of the woods yet on this car. As long as its shifting quirks are still there, I'll be looking for ways to fix it affordably. I'm allergic to rebuilders... I want to keep this A604 on the road as long as possible before I have to talk to one. My next step will be to remove the Lucas from the fluid by flushing it all out of there. I'm still dealing with a low pressure situation that is likely not the result of the bad seals Lucas is supposed to help with, and I can't have anything in there like Lucas that might thicken the ATF+4 when it's cold. Also, there is still a real possibility that there are lots of metal particles still circulating through the system, from back when the car had the dirty ATF+3. The main filter could be clogged yet again, for all I know, even though I've only put 18,000 kilometers on this car since I bought it.

At any rate, I do have to conclude that rebuilding my solenoid pack made a difference with my cold shifting issues. At the very least, it's quieter than it used to be - it will no longer scare small children when I pull up to the ice cream shop. That's not a bad thing.


More fluid and maintenance/repair information • More four-speed automatic repair information41TE, 40TES, 41TES

See the menus on top of the pages! • We are not responsible for the consequences of actions taken based on this site and make no guarantees regarding validity, accuracy, or applicability of information, predictions, or advice of any sort. Please read the terms of use and privacy policy. Copyright © 1994-2000, David Zatz; copyright © 2001-2014, Allpar LLC (except as noted, and press/publicity materials); all rights reserved. Dodge, Jeep, Chrysler, Ram, and certain other names are trademarks of Chrysler, LLC, not us. Allpar — your source for the story of Chrysler, Jeep, Ram, and Dodge cars and trucks.