Hello, Allpar Forums member or visitor! If you were a member, you would not see this ad!

Register or log in at the top right of the page...

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

02 PT Cruiser Accessories Stop Working

Discussion in 'PT Cruiser' started by jennel, Sep 28, 2017.

  1. jennel

    jennel New Member

    Joined:
    Sep 28, 2017
    Messages:
    4
    Likes:
    1
    I have a 2002 PT Cruiser, purchased new..always kept up with maintenance...just turned to 100,000 miles.
    .All has been fine till this year when the car runs fine, but ALL accessories stop working: no windows, air, radio, wipers, signals, lights...Dashboard is dead except for the Airbag light. When you exit the car, the alarm goes on as if you left your lights on...However, the battery never dies. Battery, and alternator checked out fine./Brought to car repair in Naugatuck, they did temp solution for a wire. that worked for 1 day. Car returned there, they worked on replacing the harness. This worked till I stopped for gas on the way home. Same problems....too dangerous to drive back to repair shop...any ideas?
     
  2. chuzz

    chuzz Well-Known Member

    Joined:
    Apr 3, 2004
    Messages:
    6,786
    Likes:
    459
    Sounds to me like a faulty ignition switch, but I'm not a mechanic. Go to www.ptcruiserlinks.com and sign up there. It's a dedicated PT forum and you MIGHT get the answers you need there. Just like Allpar, great members and lots of knowledge there. I'm also a member there.
     
  3. ImperialCrown

    Level III Supporter

    Joined:
    Jun 8, 2008
    Messages:
    18,132
    Likes:
    2,608
    Welcome to Allpar. There were some ignition switch and steering column wiring harness issues with these.
    If you slowly move the key towards 'start' and 'off', does it bring back operation at all?
    The wiring harness flexes between the column and dash with the tilt column. Sometimes wires wore and broke. Does slightly tilting the column up or down make a difference?
     
    valiant67 likes this.
  4. jennel

    jennel New Member

    Joined:
    Sep 28, 2017
    Messages:
    4
    Likes:
    1
    Thank you for your quick response. Like you, thought it could be ignition switch....took it out and had it tested - no change....I will definitely pop over to the ptcruiser link you provided. Thank you.
     
  5. jennel

    jennel New Member

    Joined:
    Sep 28, 2017
    Messages:
    4
    Likes:
    1
    The wiring harness has been replaced, but only fixed it for a day...I will try your suggestion re: start/off. Thank you.
     
  6. ImperialCrown

    Level III Supporter

    Joined:
    Jun 8, 2008
    Messages:
    18,132
    Likes:
    2,608
    If the wiring harness only fixed it for a day, then I would suspect that the issue is still in that area. The repair should have a 1 year warranty? They should also pay for towing back to the facility if the repair is inadequate?
    Replacing the harness would be the entire instrument panel harness, probably unnecessary. If they performed a harness wiring repair, that would have been splicing/repairing the harness at the localized damage area.
    Someone needs to go back into the column/dash area and inspect the repair. Perhaps something was missed or the repair didn't hold.
    New OEM ignition switches are inexpensive enough where it should be replaced if there is any doubts about it. It is a 15 year old switch.
     
    chuzz likes this.
  7. jennel

    jennel New Member

    Joined:
    Sep 28, 2017
    Messages:
    4
    Likes:
    1
    Thank you...will try your suggestions this week.
     
    ImperialCrown likes this.

Share This Page

Loading...
Terms of use and privacy policy. We are not affiliated with FCA. We make no claims regarding validity or accuracy of information or advice. Custom material copyright © 2001-2017 Allpar LLC.