AF: 89 B250 Hazards don't work | Allpar Forums
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

89 B250 Hazards don't work

Discussion in 'Vans' started by yawyd, Dec 7, 2012.

  1. yawyd

    yawyd New Member

    Joined:
    Nov 23, 2012
    Messages:
    26
    Likes:
    0
    I was driving my van a few days ago and had to pull over to help someone stranded in the ditch. Well I tried my 4 ways, nothing. Signals work but no hazards. So thought it was the metal relay. Nope.

    Not even a new one i took out of the package worked. So now I am thinking fuse. But when i looked at the panel, All were good. What could be causeing this? Anywho, i pulled him out with my chain on my hitch. So any help for the hazards? Thank you.
     
  2. GLHS60

    GLHS60 Well-Known Member

    Joined:
    Jun 23, 2008
    Messages:
    1,934
    Likes:
    646
    I'm assuming the metal relay you are refering to in the signal light flasher. I think you will find two of them, one for the signal lights, and one for the 4 way hazards.

    Thanks
    Randy
     
  3. ImperialCrown

    ImperialCrown Moderator
    Level III Supporter

    Joined:
    Jun 8, 2008
    Messages:
    20,957
    Likes:
    4,165
    Many times the hazard switch contacts tarnish/oxidize from non-use.
    A trick is to rapidly work the hazard button on and off many times. This will 'scrub' the switch contacts clean and the hazards should then work OK.
    There may be one separate flasher unit for the turn signals and one for the hazards or there could be one combination flasher used for both.
     
  4. Bob Lincoln

    Bob Lincoln "CHECK FAULT CODES"
    Level 2 Supporter

    Joined:
    Jul 10, 2002
    Messages:
    31,731
    Likes:
    4,974
    There may be either a fusible link or a maxi-fuse underhood for the flashers. In the mid-80s, Chrysler was using a fusible link right off the battery to power the hazards. Look for a wire underhood with a portion burned out or melted.
     
  5. TWX

    TWX DO NOT FEED THE TROLLS!
    Level 2 Supporter

    Joined:
    Jan 23, 2003
    Messages:
    8,808
    Likes:
    77
    Is there a tow hitch with some kind of interface relay box for the lights wiring? When I installed the aftermarket trailer light relay device in my Stratus my hazards stopped working. I ended up parting with the car before resolving that particular issue.
     
  6. yawyd

    yawyd New Member

    Joined:
    Nov 23, 2012
    Messages:
    26
    Likes:
    0
    Well i finally got to tracking down the hazard problem. I pin pointed it to the switch in the collum. Push it in, no signals or any light outside the van. So i have to open up the collum and change the switch inside. Or at least look it over.
     

Share This Page

Loading...
 We are not affiliated with FCA. We make no claims regarding validity or accuracy of information or advice. Copyright © VerticalScope Inc. All rights reserved.