Hello, Allpar Forums member or visitor! If you were a member, you would not see this ad!

Register or log in at the top right of the page...

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transmission problems

Discussion in 'Ram, pickups, commercial trucks' started by 48jeep, Aug 31, 2017.

  1. 48jeep

    48jeep Member

    Joined:
    Aug 6, 2014
    Messages:
    35
    Likes:
    9
    My 2013 Ram with 68000 miles on it has started to give me problems with the transmission and I was wondering if anyone has had a similar issue? The truck made a loud popping noise yesterday as I was driving it and now is stuck in 4th gear and will not upshift or downshift. I tried shutting off the motor , restarting, and going from park, to reverse, to drive. It will momentarily show it is in drive but will default to 4th gear on the instrument panel readout Reverse works. It is a four door 1500 with 5.7 hemi. Does anyone have any ideas? I will take it in to the dealer tomorrow.
     
  2. ImperialCrown

    Level III Supporter

    Joined:
    Jun 8, 2008
    Messages:
    18,136
    Likes:
    2,611
    Any fault codes?
    'Popping' as in mechanical noises?
     
  3. 48jeep

    48jeep Member

    Joined:
    Aug 6, 2014
    Messages:
    35
    Likes:
    9
    No I didn't see any codes other than the check engine light came on. I assume the codes you are talking about are stored in the computer and I haven't tried to pull them.
     
  4. Shane Estabrooks

    Shane Estabrooks Active Member

    Joined:
    Dec 9, 2014
    Messages:
    496
    Likes:
    301
    Stuck in 4th means limp mode.. more then likely the tail end of the tranny is destroyed, do you have a 66RFE.
     
  5. 48jeep

    48jeep Member

    Joined:
    Aug 6, 2014
    Messages:
    35
    Likes:
    9
    Turns out it was a solenoid on the transmission. Picked it up today and seems to shift fine. I don't think it has the 66RFE but I honestly don't know. It is the 6 speed that was available in 2013.
     
  6. ImperialCrown

    Level III Supporter

    Joined:
    Jun 8, 2008
    Messages:
    18,136
    Likes:
    2,611
    Shane Estabrooks likes this.
  7. Shane Estabrooks

    Shane Estabrooks Active Member

    Joined:
    Dec 9, 2014
    Messages:
    496
    Likes:
    301
    That is what my dealer told me that it was a solenoid, which is a common problem, but for my trans when I came back in to have it changed we found out the tranny was pooched. So after you get the solenoid changed make sure you go back for follow up to unsure everything is ok. I'm sure they'll check the oil for metal shavings telling you that it is the solenoid. The RFE45, 545, 65, 66 and 68 are all related just each has more gears(geared to application) and handles more power like above post shows. I just totally forgot about the RFE65, I thought the RFE66 was put in 1500's in one of those years or something like that not totally sure. Thank-you ImperialCrown for clearing that up for me... :)
     
    ImperialCrown likes this.
  8. 48jeep

    48jeep Member

    Joined:
    Aug 6, 2014
    Messages:
    35
    Likes:
    9
    I had asked for them to save both the solenoid and the filter but I was too late.They had thrown them out before I got back to town from a trip.
     
    Shane Estabrooks likes this.
  9. 48jeep

    48jeep Member

    Joined:
    Aug 6, 2014
    Messages:
    35
    Likes:
    9
    I was just curious if you had noticed a "shuddering " before you had problems with your transmission. "Shuddering" is about the best way I can describe it. It doesn't do this now and I think that may have been the solenoid acting up. I originally thought that maybe it was the MDS doing its thing.
     
  10. Shane Estabrooks

    Shane Estabrooks Active Member

    Joined:
    Dec 9, 2014
    Messages:
    496
    Likes:
    301
    Yes ... do you feel it before letting off the fuel of after... Before is very bad, it seems that I may have had a programing issue. I'm still investigating the programming issues but hope all you had is a sensor.
     
  11. 48jeep

    48jeep Member

    Joined:
    Aug 6, 2014
    Messages:
    35
    Likes:
    9
    Apparently it was the solenoid on my truck. The shuddering went away after it was changed. It wasn't really bad but it was noticeable.
     
    Shane Estabrooks likes this.

Share This Page

Loading...
Terms of use and privacy policy. We are not affiliated with FCA. We make no claims regarding validity or accuracy of information or advice. Custom material copyright © 2001-2017 Allpar LLC.