Allpar Forums banner

62te

  1. 1995-2017 FWD Sedans, Coupes
    Hey, i have a Chrysler sebring 08 with 6.2k miles. While casually driving the check engine light got lit and it went into limping home mode. The error code recovered was p0734 but where i live in sweden there is no mechanic that has experience with chrysler. They tried flushing the transmission...
  2. Repairs, Maintenance, Help
    Recently my 09 VW Routan started, rather suddenly, shifting late and hard. I visually inspected the pan and saw a small leak. Thinking it may be low on fluid I dropped the pan to replace the fluid and filter. Inside the pan I found this a part of a gear. After looking around it looks like the...
  3. Repairs, Maintenance, Help
    Hi ya everyone Anyone in here pulled a 62TE out of a 2012 chrysler 200 yet? I have a nice low mileage replacement transmission to put in it, my only real concern is that i don't see an inspection cover to gain access to torque converter bolts..i have never seen a fwd tranny i couldnt unbolt the...
  4. Projects, mods, restoration
    I have a 2008 Caravan with the 3.3l i'm not finding any reason I can't swap in a 2.7l from a 2002 Sebring... They both bolt up to derivatives of the A604. Sebring being the 41TE and the Caravan having the six speed version dubbed 62TE... Apparently only the Bell housing bolt patterns and valve...
  5. Repairs, Maintenance, Help
    Hi. Stupidly bought a 2008 Chrysler Pacifica. Rebuilt 62te awd trans the next day. Short story, has harsh 2>3 shift, thunk into 6th, thunk down to first. Thunks more audible, 2>3 is ca-lunk. Was brick wall calunk, dealer flash cut that down. Just returned to rebuild shop for a week+...
  6. Minivans · Pacifica
    I have a 2009 Town and Country with 95k on it. I have no trouble codes. The transmission shifts great from 1st to 2nd and 3rd to 4th. 2nd to 3rd is pretty rough at higher rpms (3000-4000) but shifts fine at lower rpms. It also shifts fine going downhill, but rough uphill. I did a transmission...
  7. Minivans · Pacifica
    65,000 mile 2013 Town and Country snap ring broke and took out the Transmission. Just wondering if this is a common problem? I understand there has been issues with the 62te transmission.
Top