Allpar Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Need help asap to car just died in traffic got towed home and I can't get it started.
I put a new fuel pump, check plugs for spark there good put a new coolant temp switch. All fuel injectors are new. I'm lost don't know what to do next
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,674 Posts
Welcome to Allpar.
Any fault codes? Three things are needed to run a gasoline engine: spark, fuel and engine mechanical (timing/compression).

SPARK: You have good spark. You replaced the fuel pump and injectors (did a diagnosis point to them?).

FUEL: Does the engine fire up briefly with a shot of solvent/cleaner into the throttle body? You can have good fuel pressure in the fuel rail, but if the injectors aren't opening, you still basically have no fuel.

ENG. MECH: Do the cams turn while cranking? This has a rubber timing belt that should be replaced every 105K miles (170K km). It may look tight, but they can shed their teeth at the crankshaft sprocket.
This is an interference engine. Valve damage might have occurred if they crashed the pistons. Replace the water pump & tensioner pulley as they are wear issues.


Font Circle Parallel Diagram Drawing
 

·
Registered
Joined
·
9,263 Posts
He posted in the welcome to allpar header too, Walt. He says that it's got a new timing belt too.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thanks for the reply timing be belt is new well maybe 7/8 months old water pump h balancer all at same time I have a feeling not enough psii in gas line I follow instruction how to pressure up lines turn on wait till pump stop turn off wait 5 seconds turn on for,5 times and almost starts but it don't see
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,674 Posts
Fuel pressure should be around 50 psi (345 kPa). Does it start and run briefly with a short spray of carb cleaner into the throttle body? Use caution when using flammables.
Problem in the fuel tank? Saddle-style tank has one pump, two senders. I've seen them siphon gas into one side and run out of gas on the other while the gas gauge shows it is not empty. Out of gas?
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,674 Posts
No. One fuel pump (passenger side). Two senders/two fuel pickup tubes (one on each side).
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Your saying there's 2 fuel pumps I have to check that out I only replaced the driver side fuel pump I didn't know there's another
No. One fuel pump (passenger side). Two senders/two fuel pickup tubes (one on each side).
Ok one fuel pump 2tubes ok here's what I did I just changed a fuel pump on the driver side 2 tubes on the bottom of pump inside the tank and there was also 2 tubes on top outside
of the tank same as the one I took out
No. One fuel pump (passenger side). Two senders/two fuel pickup tubes (one on each side).
Ok I just replaced fuel pump on the driver side with 2 lines inside of tank and 2 lines on top of pump outside the tank
 

·
Registered
Joined
·
16 Posts
When you turn the ignition to the ON position, without attempting to start, do you get the normal set of warning lights and other indications? Or, does "something" appear different on the instrument cluster?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Let
Ok one fuel pump 2tubes ok here's what I did I just changed a fuel pump on the driver side 2 tubes on the bottom of pump inside the tank and there was also 2 tubes on top outside
of the tank same as the one I took out

Ok I just replaced fuel pump on the driver side with 2 lines inside of tank and 2 lines on top of pump outside the tank
Ok one fuel pump 2tubes ok here's what I did I just changed a fuel pump on the driver side 2 tubes on the bottom of pump inside the tank and there was also 2 tubes on top outside
of the tank same as the one I took out

Ok I just replaced fuel pump on the driver side with 2 lines inside of tank and 2 lines on top of pump outside the tank
When you turn the ignition to the ON position, without attempting to start, do you get the normal set of warning lights and other indications? Or, does "something" appear different on the instrument cluster?
I get regular set of lights everything is as usual many new parts for got a whole list of them it died in traffic and has yet to start
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
Ok one fuel pump 2tubes ok here's what I did I just changed a fuel pump on the driver side 2 tubes on the bottom of pump inside the tank and there was also 2 tubes on top outside
of the tank same as the one I took out

Ok I just replaced fuel pump on the driver side with 2 lines inside of tank and 2 lines on top of pump outside the tank
I got a question the 2 lines in top went in pretty easy and are ad they should be I had trouble with the 2 lines inside the middle round one and the kind if flat one in the edge that does not feel tight back m wondering if that may be my problem what is that lube for also thank for replying and trying to help figure this out I own
 

·
Registered
Joined
·
973 Posts
Maybe I missed it - did you have a chance to check for fault codes?
 

·
Registered
Joined
·
973 Posts
Well I was wondering about computer but not sure I'd go there $$$$ without some validation... like a bad computer code.
Even if you erased the codes, on the next key on and crank you might regenerate a code to give a clue.
 
1 - 17 of 17 Posts
Top