Allpar Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I replaced both thermostats, both blend door actuator and blower motor and recharged freon. And now driver side is blowing hot air and passenger cold air. I'm in AZ triple digit weather and it's killing me. Input plz
 

·
Virginia Gentleman
Joined
·
14,805 Posts
Sounds like a blend door is stuck or inoperative. With engine off and the ignition on (engine not running) can you hear the blend doors move?

You may need to have a dealer or qualified shop check for error codes. A simple scanner won't be able to retrieve those error codes.
 

·
Registered
Joined
·
4,691 Posts
. . . I replaced both thermostats, both blend door actuator and blower motor and recharged freon. And now driver side is blowing hot air and passenger cold air.. . . .
There is only 1 blend door actuator located on the left side of the HVAC air distribution housing under the instrument panel. See attached image. Under the temperature blend door actuator there are 2 temperature blend door shafts linked together by lever arms. Make sure these are attached to each other and operate together.

Temperature Blend Door Levers.gif
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thank you, come to find out it was clogged and needed to be recharged with freon. Ultimately there is a minor leek in the high pressure valve/hose. I bought the part only to find out I can't do it by myself being that I don't have the tools to release freon or moisture from it.
 
1 - 4 of 4 Posts
Top