Allpar Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi! New member, and looking for advice.

I already searched whatever I could on the subject and haven’t found much of anything to assist.

I am rebuilding my truck and have done a fair amount already. Starts, runs, all good. Ran into trouble with my lights, running lights, and signals.
I did swap out all my sockets with wedge types, rear end is working perfect. Front end not so much.
I picked up and installed a headlight wiring kit that pulls from the battery vs through the wiring. Doing this allowed me to redo all my wiring, trimmed out extra wiring for the headlight from factory wiring, as my kit simply bypasses it all but uses the drivers side as a signal for the relays.
What’s happening tho is I swapped all the factory bulbs with LEDs, and I finally found a flasher that actually works with it, however it works properly only when the lights are off. As soon as I turn my running lights on and hit the signal my tail lights work as it’s supposed to, but the front, my turn signals stay lit, and my marker lights flash.
As far as I am aware, my rewiring is good, I have strong ground wires, I can’t say I know how to use a multimeter, but it’s on m todo list! I have no resistors installed. My hazards work as intended(I know it’s a different circuit). My components on the column is new, new headlight switch. My new headlights have an LED DRL halo I have tied into the marker lights, but that shouldn’t draw anything that conflicts.

If there’s anything more, I’m happy to answer, and thanks for taking the time to read the story!
 

·
Registered
Joined
·
6,050 Posts
You are back feeding the system probably through the turn signal switch. OR you have a bad ground and it is backing up through the light bulbs. You will probably see the markers off when the back signal is on. That indicates a backfeed from somewhere.
 

·
KOG
Joined
·
7,032 Posts
Check the grounds again.
 
  • Like
Reactions: BlackSheep01

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thanks for the responses guys!

Damn grounds. I added in a few. Upgraded the engine to battery, added in another direct frame to battery cable, bigger grounds wherever I could find an existing grounding point. Only other thing I can think of is redoing a rear ground I seen.

Is there a place I could tie another ground into in the lighting circuit?
 

·
Super Moderator
Joined
·
32,047 Posts
It's OK to replace existing grounds with same or larger wire, but don't add to the number of grounds. You will create ground loops that will adversely affect the voltage to your sensors and it will hurt vehicle operation.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Sorry for the delay, been away from the truck until today.

I did notice my left tail light goes dim when the DRLs are on and the right side is blinking. When the left is flashing the right side doesn’t go dim tho. However the fronts don’t seem to do much of anything different with the extra grounds on or off.
 

·
Super Moderator
Joined
·
21,398 Posts
It still sounds like a poor grounding issue. Are the bulb sockets themselves the problem? I had to replace some for contact corrosion failures.
Is there a brass tongue terminal that makes contact the bulb ground shell in the socket?
 

·
KOG
Joined
·
7,032 Posts
Another weird possibility is a bad bulb. It's very rare, but filaments in a bulb have been known to bend and touch. Not likely, but bulbs are cheap and if they haven't been replaced before they're way past their lifetime. I'm still with IC on this, bad ground or socket.
 

·
Registered
Joined
·
8,094 Posts
Stupid question, I'm sure, but speaking of bulbs, are you using the correct number in the sockets? I'm pretty sure the brake light/tail light/turn signal should be an 1157 and backup lights should be 1156. I had an experience with a Nissan truck I bought years ago having the wrong bulbs in the sockets. I didn't notice the issues with them when I bought the truck in the daytime and driving it the 700 miles home, when I had to turn the head lights on and use the turn signals, then the fun began. It only took me a couple of hours to figure out what it was once I got it home.
 

·
KOG
Joined
·
7,032 Posts
And I have seen people manage to put 1157 bulbs in backward. They have high and low pins, nearly impossible to get them backward, but they're not idiot proof. Idiots are very talented and inventive.
 
  • Like
Reactions: chuzz

·
Registered
Joined
·
5 Posts
Discussion Starter #11
Well I converted my tail lights, reverse, and signal lights all to the 3157/3156 sockets. The existing 1157 style sockets were all pretty bad. Redoing all the wiring with testing before wrapping up. The sockets are all good and clean.
Also all the bulbs are LEDs which only plug in and work one direction.
Now I suppose it is possible that a couple bulbs could be working incorrectly, but for instance, when the one taillight dims out, it looks like it’s not getting enough power. That works with the poor ground, which there’s one I hadn't really touched under the truck. I was thinking of splitting the loom along the frame under the box and seeing what’s going on. There is a random wire run along the loom I don’t know what for, so it’s possible something is amiss there.
 

·
Super Moderator
Joined
·
32,047 Posts
A light dimming can be a poor ground, or it can be a partial short of the power to it, under the threshold of the fuse rating, or a bad connection at the power wire.
 
  • Like
Reactions: chuzz

·
Registered
Joined
·
5 Posts
Discussion Starter #13
Finally got it.
Fixed all the grounds, cleaned up any connectors I found, wrapped everything up I could nice and pretty (some wiring in the back was rubbed through on the passenger side I had missed previously). Tested out bulbs and it’s all good now.
Neat bonus: since everything is working properly now, there’s no feedback and front signals flash properly, marker lights flash, and whichever side is signalling, my led drl cancels.

Thanks for the help guys! Everything is appreciated!
Now onto the rest of the truck
 
1 - 13 of 13 Posts
Top