Allpar Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi all, I own a 1995 Lebaron and recently im having some weird problems with it.75% of the time when I start the car I don't hae power mirrors or radio power? Then ill tap on the fuse panel and cycle the key and it starts working again.I'e pulled the two 30amp breaker fuses in the fuse panel and replaced them even though they aren't related to the two devices not working because the were loose in the tabs.Not sure if there was a purpose to that but regarless.I checked the radio harness and the power thats missing to make it work occasionally is the 12olt battery power,not the acc power weird huh?? Im lost ,if the a fuse panel problem or relay problem and if so which one?? Im also looking for a power window switch and hub cap ,the 4 window controller switch drier side and the gold accent hub cap blew off when I hit a hole.Thanks a million for any guidance!!!
 

·
Registered
Joined
·
1,828 Posts
Shouldn't be a relay problem, there's no relay for the radio or mirrors. It could be that the wires that connect to the sockets that the fuses sit in are loose.
 

·
Registered
Joined
·
1,087 Posts
I'd check the ignition switch and the it's connector plug and related wiring. Remove the three Torx screws from the underside of the steering column cover and take a close look at the end of the ignition switch where the wires plug in. I've seen several of these connectors and switches get overheaded due to corrosion causing all sorts of odd electrical issues. Look for signs of melting, brown, discolored connector plastic and wiring. The accessory power passes through this switch. New ignition switches are available through the aftermarket. Not sure though if this would have any effect on the power mirrors as they aren't controlled by the ignition switch.

Also check the body grounds at the battery terminals and where they attach to the inner fender by the battery.
 
1 - 3 of 3 Posts
Top