Allpar Forums banner
1 - 3 of 3 Posts

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,913 Posts
These are all communication bus faults and probably not related to any sensors. The 'bus' interconnects all the various modules so they can communicate information with one another.
The cluster doesn't know what gear you are in or how fast you are going, so all the boxes are lit and the speedo/odo are inop. The warning lights are lit and those modules are probably all storing 'no communication' fault codes themselves.
Diagnosis of the bus can get complicated. A voltmeter and wiring diagram would help. The twisted-pair bus is usually a white and a violet wire, possibly with a colored tracer stripe.
The 2.5 volt bus supply originates in the cluster and by unplugging other modules one at a time you may find which is pulling the bus down (if this is the issue). The bus is sensitive to moisture and corrosion knocking it down and taking the modules off-line. Broken cluster circuit board solder joints is another possible cause.
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,913 Posts
If the solder joints appeared solid, then they are probably OK. The comm bus twisted-pair is in the connector to each computer module.
By unplugging and re-plugging connectors, you may have wiped some oxidation from the terminals and restored a connection. You might try unplugging and replugging the TCM connector to see if the TCM comm fault (100.3 and P1698) disappears.
The battery disconnect code (400.1 and P1684) will appear whenever a module is powered down unexpectedly, it can be ignored.
P0500 is the speed sensor code for the 3-speed automatic and shouldn't be there. Has this cluster been changed?
The loopback failure code may indicate a failed instrument cluster if the code is erased and returns. A last ditch attept at repair would be to reflow the solder joints and see if loopback returns.


Symptom:
LOOPBACK FAILURE
POSSIBLE CAUSES
INSTRUMENT CLUSTER
TEST ACTION APPLICABILITY
1 Turn the ignition on.
With the DRBrecord and erase DTC’s.
Turn the ignition off, wait 15 seconds, then turn the ignition on.
With the DRBread DTCs.
Did the DTC reset?
YesReplace the Instrument Cluster in accordance with the Service information.


P1698-NO BUS MESSAGE FROM TRANS CONTROL MODULE
Set Condition: No bus messages from the TCM for 20 seconds, two trips required.POSSIBLE CAUSES:
INTERMITTENT CONDITION
COMMUNICATE WITH TCM
PCM
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,913 Posts
If you still have the 100.3, I would treat it as a P1698 and diagnose it as the same: No comm with the EATX.
Could be cluster, PCM, TCM or the wiring.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top