Allpar Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
My fiance bought a 2002 3.7 liberty 4 months ago with 96,000 miles on it from a wrecking service. Someone had the jeep towed in and repaired by a mechanic there and couldn't pay for it so he put it on craigslist.A month ago, a pin hole developed in the radiator on the plastic end towards the battery. While replacing the radiator, I noticed rust or something similar all through the cooling system. I flushed it out the best I could, and added distilled water to the new mix. Well, the other night after a huge storm we got gas.About 1/3 a mile after driving away the jeep started missing for a few seconds and then quit running.She tried to restart it but it wouldnt start, barely even tried to start.As I was looking around under the hood, I noticed the upper radiator hose wasn't pressurized, but the coolant tank definetely was .Then her father came and had her keep trying to start it, and something kinda banged inside the motor, sounded like the top half of the motor to me.Now it won't turn over at all by the starter or by the crank pulley with a breaker bar. I fear it's a skunked motor, or possibly hydro-locked(i hope) .If it is blew up, does jasper sell re-mans or who would be better?
 

·
Registered
Joined
·
3,015 Posts
I would expect Jasper to sell remans, but another option would be a salvage yard engine. Especially consider a U-pull yard, if you want to keep costs down. Did the engine overheat prior to dieing? Is there any coolant in the oil, or oil in the coolant? Was the oil level ok?
 

·
Registered
Joined
·
8,042 Posts
Maybe it hydro locked on her. It sounds like maybe the engine is full of coolant and the coolant won't compress in the cylinders. I'd try removing all of the plugs and seeing if it will spin. I doubt it, but it's worth a shot.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Any chance that the starter is stuck against the flywheel causing it not to turn over ? I pulled the plugs out, rotated the motor backwards about 60 degrees, and then tried to start it by the key.The motor rotated (turned over) twice so I let off the key. Then and since then she won't budge either by starter or breaker bar. Something else kind of weird, when I put my battery charger on the battery, it will pull 12 amps like somethings draining the battery.Then , after I fully charge the battery and bump the starter a couple times, it's already pulling 4-6 amps again that quick.Weird.
 

·
Super Moderator
Joined
·
21,362 Posts
[sub] The 'bang' that you heard may be something floating around in the bell-housing and jamming the t/converter?[/sub]
[sub]Pull all 6 plugs to verify that the cylinders are dry, although this new diagnosis seems to be turning direction now.[/sub]
[sub]A battery will draw hard for repeated starter use and dropping battery voltage. I would take some time to let the battery fully charge and then re-test it. It may just need recovery.[/sub]
[sub]There may also be 2 problems here.[/sub]
 
1 - 6 of 6 Posts
Top