Allpar Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2005 PT Cruiser 2.4l (non-turbo) that has over 100,000 miles. The check engine light came on and the codes were 0303 and 0340. I have had new spark plugs, new coil, new camshaft position sensor and new fuel injector in #3 cylinder. The engine light is still on and still has code 0303. What else could be the problem?
 

·
Registered
Joined
·
2,978 Posts
I'm assuming you changed the spark plug wires as well. Does it idle smoothly?
 

·
Registered
Joined
·
148 Posts
stefnep said:
I have a 2005 PT Cruiser 2.4l (non-turbo) that has over 100,000 miles. The check engine light came on and the codes were 0303 and 0340. I have had new spark plugs, new coil, new camshaft position sensor and new fuel injector in #3 cylinder. The engine light is still on and still has code 0303. What else could be the problem?
My code list denotes p0303 as a "misfire".
[SIZE=11pt]P0340 Camshaft Position Sensor Circuit Malfunctio[/SIZE]n.


So please tell us? Was the old sensor defective?
Was the multmeter on the old fuel injector showing a bad injector? why was this replaced?
So are you actually hearing a "misfire" or are you spooked by the reoccurring Code?

Did you reset the codes or just use the 3 starts and the 0340 went away?

You can test the wires too. Maximum should be approx 25k ohms per chord.

Just throwing parts against the wall hoping something will stick? Gets frustrating at times.
 

·
Registered
Joined
·
31 Posts
cyl 3 misfire,compression test sould be about #3 list.
now some codes claim cyl 3,others are third in firing order,so its actually 1,3,4,2-cylinder 4

had one of mine dropping a cylinder,2 plugs were arcing on outside of plug,replaced plugs and wires.
one open wire will fry a coil in short order.
 
1 - 4 of 4 Posts
Top