Allpar Forums banner
1 - 20 of 78 Posts

·
Registered
Joined
·
476 Posts
Discussion Starter · #1 ·
Please listen to this video of a jeep on youtube that has the same noise that I have.
In the last two weeks, I have spent $1000 trying to stop that noise. It happens while going slow over bumps. Coming from the passenger side center or wheel area. I replaced STRUTS AND MOUNTS,
Inner Tie Rods, Sway Bar Links, all for both sides. Front Motor Mount, passenger side lower control arm and still have the thumping clunking noise. It is driving me insane. Please advise.
Here is the video
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,655 Posts
The rubber sway bar bushings?
 
  • Like
Reactions: TaxiGirl

·
Registered
Joined
·
1,342 Posts
When you replaced the lower control arm, was that a complete assembly with the lower control arm bushings and ball joint?
 

·
Registered
Joined
·
476 Posts
Discussion Starter · #7 ·
When you replaced the lower control arm, was that a complete assembly with the lower control arm bushings and ball joint?
Ever heard of the Joust bushing going out? I thought it may be the other motor mounts or transmission mount but just now I have someone jump in and rev up the engine and there is no movement
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,655 Posts
No, the links are item# 15. The bushings are item# 14 and can be serviced separately.
 

·
Registered
Joined
·
1,342 Posts
Considering that the wheels maybe fighting one another at steering the vehicle or pulling to one side or the other when going over bumps. This will wear the tires. Try not to drive it too long before you get an alignment.
 

·
Registered
Joined
·
793 Posts
C/V joint
 

·
Registered
Joined
·
476 Posts
Discussion Starter · #17 ·
No, the links are item# 15. The bushings are item# 14 and can be serviced separately.
Thank you for your help. I will change out bishings next. I am hearing same noise in center of emgine compartment. What are those big bumpers tthat are next to the other end of the control arm? Not the ones called isolator but the other one? When i looked at it, it seemed to be worn. Also, the sway bar bushigs probably had about 1/16th inch gap between it and the sway bar arm. Does that tell yoy that they are bad?
 

·
Registered
Joined
·
11,099 Posts
Check to see that the steering rack is secure. Have a helper turn the wheel back and forth while you watch the steering rack for any movement. The steering rack housing may have come loose from its mounting points in one or more areas.
 
1 - 20 of 78 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top