Allpar Forums banner

2013 Town and Country uConnect Radio and Dvd

8432 Views 2 Replies 3 Participants Last post by  link3721
Just got a 2013 T&C base model with the RBZ model uConnect entertainment system. It has the single rear video monitor and a single CD/DVD slot. It came with two pairs of wireless headphones that each can be set to receive on channel 1 or 2.

Any idea how I can have the DVD audio sent to the headphones and the main speakers play the radio?

Fiddling with the controls for the Rear VES seems like it should be the answer - giving me the chance to split the rear screen and signal so wireless 1 and 2 can independently use the FM/AM/SAT/HD/Disc signals. But alas, no combination allows the driver to hear anything other than Mickey Mouse Club if the DVD is playing.

Other forum posts mentioned a "headphone" button on the remote control. My remote control has only a headphone mute button. Those forum posts were from 2010 and I presume there have been quite a few changes since then.

Of course the tiny reference guide and DVD manual for the new T & C are useless with nearly no details and confusing/vague syntax.

I've seen so many of these things on the road, there must be SOMEONE who has already figured it out!

Any insight greatly appreciated! THANKS!
1 - 3 of 3 Posts
I know this post is a little old but did you figure out your Uconnect system? I have a 2013 also and it took me a few minutes to figure it out also. They don't make it real easy to figure these things out. But, you should be able to switch to any other media selections while the DVD is on and the headphones are on. Some settings could not be allowing yours to separate the signal. I would try to reset to default settings and then turn the DVD player and headphones on. You should be able to change to satellite radio or FM/AM radio while the DVD still plays on the monitor in back. The radio should come through the speakers in the van and the DVD will only play through the headphones. If it doesn't work then you could have a problem because this all I have to do to make mine work.
You should just be able to hit the radio hard button. The VES channels control what is sent to the headphones only. The VES sound shouldn't change when you hit the radio button and the main speakers should go to the radio. The VES icon should also remain on the bottom of the touchscreen so you know it's still running.
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.