Allpar Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all. I'm new here, having issues with my 83 Rampage. Not positive on if I have a 5520 or 6520 holley. And what styles/types came in what years. I bought a reman off of eBay for cheap, and the connections/wires do not hookup nor match up. When I start the engine, it has an erratic high idle. Only adjusting timing can bring it down to 1500rpms, and it should be around 900, and when it's at 1500, its a rough 1500. I am just not sure where to start or what I'm doing wrong.
 

·
Super Moderator
Joined
·
37,865 Posts
I am guessing if the wires don't match up you have a "car" carburetor and not a "truck" carburetor. There were more electronic controls on the "car" carb than the one that should be on the Rampage.
Without the electronics hooked up, it would be hard, if not impossible, to make it run right.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I am guessing if the wires don't match up you have a "car" carburetor and not a "truck" carburetor. There were more electronic controls on the "car" carb than the one that should be on the Rampage.
Without the electronics hooked up, it would be hard, if not impossible, to make it run right.

It seems I purchased a 5220 holley, with the thought it was a truck carb. But I added truck into my search and some showed up that looked applicable. But they didn't seem to have the idle speed solenoid/kicker. The number on mine is: 40391-1 whether or not it belongs on my vehicle, I am unaware.
 
1 - 3 of 3 Posts
Top