Allpar Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
698 Posts
Discussion Starter #1
Hey guys,

My 90´ Voyager (1st Gen.) had a transmission failure arround 160 000 KM.
The pre owner replaced the trans, but i don´t know the year of the vehicle they put the new trans out.

I just recieved my R4761846AA TCU.

Should it work on every trans put in there or only on the year the trans was made?
Wiring harness is the original one, also the factory TCU is still in. Never even touched, i guess. Works fine right now, only the common lazyness from the old TCU. Didnt tried the new TCU yet or checked for pin 49.

It´s a 1990 A604, 3.0 Mitsu,

I have not observed this point...


Please let me know,

Thanks a lot
Kevin
 

·
Super Moderator
Joined
·
36,919 Posts
What software is loaded on the R4761846AA box? You should have 4796121 to be the latest for a 1990 3.0 minivan. Earlier revisions include 4713228, 4728600 and 4761846.
 

·
Registered
Joined
·
698 Posts
Discussion Starter #3
valiant67 said:
What software is loaded on the R4761846AA box? You should have 4796121 to be the latest for a 1990 3.0 minivan. Earlier revisions include 4713228, 4728600 and 4761846.
Yes sir, the 4796121 is on the new TCU.

But i only have to care about the year of the vehicle itself, not about the new trans right?
 

·
Super Moderator
Joined
·
36,919 Posts
If the transmission is wrong for the car, you would be out of luck. The same part is used for 1989-1991. 1992 is an odd year, it might work with the 1991 electronics. But in 1993 everything changed and a 1993 computer won't play with your 1990 electronics. If what is in there is working, the new one should too.
 

·
Registered
Joined
·
698 Posts
Discussion Starter #5
Oh yes i forgot...2 years of using the sam software on this platform.....OK that makes sense, yes the old software / wiring harness has never been changed, works fine i´d say.

Thanks for clearing this one!
 
1 - 5 of 5 Posts
Top