Allpar Forums banner

"94 3.5L, hard start when hot

2768 6
Starts fine when cold and if started soon after shutdown. If the engine hot soaks for awhile it takes much crancking to start and runs rough for a few seconds. Getting excellent fuel mileage.

AutoXray shows no fault codes.

I suspect the fuel regulator needs replacing. I sometimes smell gasoline after shutting the engine off.

Any Ideas on finding fault?
1 - 2 of 2 Posts

· Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
17,276 Posts
There was a safety recall #790 that involved replacing the fuel pressure regulator o-rings and injector o-rings and a right bank plastic fuel rail if they were leaking fuel.
A scan tool may show a big difference between the right and left bank fuel trim adaptives. Usually the right side was way negative in trim value compared to the left side. Check with your dealer to see if it was completed or if you are still eligible for the recall. Have your VIN# handy.
Google: Chrysler recall #790.
 

· Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
17,276 Posts
The right plastic fuel rail can still crack after the recall is performed. It isn't automatically replaced, just inspected and strengthening braces glued on. It is only replaced if there are signs of leakage. The braces were not a permanent fix IMO.
The dealer may re-perform the recall if you ask. That would hinge on parts availibility and Chrysler covering it again.
The quick-release couplings should be 'pinch and pull'. The barbs stay on the tubing. I agree that old underhood plastic becomes brittle and should be handled with care.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top