Allpar Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
So I got this odd problem when I signal left with my parking lights on it signals as if I have a burnt out bulb, before you suggest its a bulb I went to dodge and got all new bulbs, I remember at one point it used to do ot signalling right but now its only left, when I turn my lark lights off it signals normal any ideas?
 

·
Super Moderator
Joined
·
36,916 Posts
Since both sides share the flasher unit, it is either in the bulbs or wiring. A common problem is corrosion in the bulb socket or corrosion where the socket plugs into the wiring harness. All it takes is a little corrosion, or a bad ground, to make this issue happen.

Put the 4 way flashers on and walk around the vehicle. Compare the lights on one side to the other. Look for a bulb that isn't lit or is dimmer than the other side. Repeat with the parking lights on as well.
 

·
Super Moderator
Joined
·
21,351 Posts
Welcome to Allpar. I would go with a bad ground on that side as well, front or rear.
You may notice a bulb with one filament brightly lit and the other dimly lit. This is feedback through the bulb because of a high resistance to ground.
Bulb sockets, sheetmetal ground terminal screws and old trailer wiring are common sites for corrosion.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
ok so i was playing today and it seems like if i pull down the turn signal stalk to signal left, if i pull it down part way before full on but in between full click and center it will signal even faster, sometimes i can even make the left signal blink normal for a second before it goes crazy fast could it be the stalk itself failing? Also upon further inspecting the orange section rear left bulb the socket is really rusty however all my lights are the same brigtness.
 

·
Super Moderator
Joined
·
21,351 Posts
I would try to clean or replace the LR socket contacts.
The plastic steering column halves separate after removing screws from the lower half. The multifunction switch can be removed and disassembled carefully (watch for the spring or other floating parts) for terminal cleaning or replaced if it has a bad contact spot.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
So I fixed the fast flash issue turns out the front turn signals require 1295na I had 1156. It's funny because mopar does not stock them anymore I had to go to a parts store to get them. All good now though.
 
1 - 8 of 8 Posts
Top