Allpar Forums banner

94 grand cherokee turn signal problem

1968 7
So I got this odd problem when I signal left with my parking lights on it signals as if I have a burnt out bulb, before you suggest its a bulb I went to dodge and got all new bulbs, I remember at one point it used to do ot signalling right but now its only left, when I turn my lark lights off it signals normal any ideas?
1 - 3 of 3 Posts

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
16,988 Posts
Welcome to Allpar. I would go with a bad ground on that side as well, front or rear.
You may notice a bulb with one filament brightly lit and the other dimly lit. This is feedback through the bulb because of a high resistance to ground.
Bulb sockets, sheetmetal ground terminal screws and old trailer wiring are common sites for corrosion.
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
16,988 Posts
I would try to clean or replace the LR socket contacts.
The plastic steering column halves separate after removing screws from the lower half. The multifunction switch can be removed and disassembled carefully (watch for the spring or other floating parts) for terminal cleaning or replaced if it has a bad contact spot.
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
16,988 Posts
Yes, wrong bulbs would do that. Good catch.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top