Allpar Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I realize this has been kicked around for years but I need help here.

I have changed the dirty fluid/filter and put in (flushed to 12 qts) new Castrol atf+4.

I have adjusted the throttle pressure linkage for a light throttle 1-2 shift at 18 mph but shift 2-3 still has a small flare at 31 mph with positive grab into 3rd. Heavier throttle reveals less or no flare and much higher (50-55 mph) shift into 3rd.

There is a Chrysler bulletin for this issue: Number 21.23.95 where they change the VALVE BODY part no 4659879, the kickdown brkt part no 4669863,and fluid.

My 2 Questions are: What was modified in the valve body that cured the flare issue? I want to do this mod to my valve body.
Is there a different brkt that I should be using for kickdown? Wondering if it is different.

Bob
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Imperial Crown,

I have the van 3.0 with the 31th trans but the bulletin is from 95, 96 Neon w/ 31th as linked below:
http://neons.org/neontsb/TSB/21/212395.htm

I notice that the flare ends with a positive grab to 3rd gear- no slide into 3rd. It reminds me of a flat shift with much less throttle. This leads me to believe something is wrong in the valve body. This is further reinforced with the availability of the Shift Correction Package 404-670 Kit for Chrysler. This kit is a modify to the body only.

The fluid was dark red and plenty of sludge to clean out of the pan and magnet but the filter did not appear filthy.

I appreciate if you can comment further on this situation.

bob
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top