Allpar Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
My fathers '97 Grand Voyager 3.3 has been experiencing a fairly intermittent stalling issue, while driving. Happens most frequently when slowing down to stop, and sitting at traffic lights, or sometimes just driving around town. Will not stall on highway, at consistent speed. No ignition codes. Has a radiator cooling fan code, can't imagine that has anything to do with stalling. (It has new IAC, wiring around plug and harness looks great. Van will idle when it's happy.) I should also mention that this van does have a BCM short somewhere, doors will lock themselves, and tail light/side marker light circuit also has an issue. Before I continue, I need to mention that this van is a work/beater van. It is not pretty and does not warrant, "professional", fixes, or premium parts. It just needs to run and drive.

Now, back to the stalling problem. It tends to stall within the first 5-10 minutes of driving for first time of day. If I let it sit for 10 minutes on side of road, it'll fire right back up, and run great for rest of day. Occasionally, it'll quit twice on the same day, then fire up and run great after 10 minutes.

I can't figure if this could be an ignition issue, as if the coil is getting hot, like on a lawn tractor, or of it is a BCM/computer/sensor issue. I thought to myself if maybe the security system immobilizer could be killing ignition, based on the door lock short. Just a thought there.

Again, there are no ignition codes, or any engine related codes either. Engine is not missing or stumbling, during normal driving. One time, when engine fired up after stalling and waiting the 10 minutes, revved engine to limiter, and engine was backfiring, sounding like out of throttle body. Leading me to think ignition issue. Just another thought there as well.

What are you guys thinking?

Thanks!
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
Do you know why the IAC (idle air control) valve was replaced? Were the orifices inside the throttle body at the entrance and exit of the IAC bypass cleaned? If this passageway has carbon build up this could interfere with proper airflow as the engine warms up. When returning to idle state, this passageway must be clear so the engine management logic can control the proper amount of air intake so as to effect a proper idle condition.

Remove the upstream side of the throttle body intake. Open the throttle valve and spray a liberal dose of carburetor cleaner into the throttle body and onto the butteryfly valve. Use an old toothbrush to scrub all internal areas and wipe clean with paper towel. With a clean throttle body intake it may take several days for the engine management system to relearn proper settings for the IAC and return the engine to a normal idle situation.



The third generation van had a feature in the BCM such that all doors and the rear liftgate would lock automatically once forward motion was attained and vehicle speed reached 10 - 15 mph. Is that the occurrence? Or are the doors locking randomly at highway speeds? This automatic locking feature is programmable by the user and can be disabled.



If you give the associated radiator fan cooling code one can pinpoint the area to investigate.



BCM is attached to the junction block which is located above and to the left of the brake pedal arm. See attached image.

View attachment 89556

I replaced IAC, knowing it could be likely to cause issues, as I have had similar problems with IAC with my Voyager in the past. I did not clean TB though, I will go ahead and do that.

The doors self lock when van is parked, without key in ignition. Using power lock switches on inside driver and passenger side doors, will cause doors to unlock, then lock again with one press of switch. I disconnected magnet type door sensor on passenger side sliding door, they no longer self lock, but locking switches on driver and passenger side still malfunction.

Radiator fan stopped functioning, the fan relay near air box is highly suspect. Instead of replacing relay, (this is a beater van, and my father is very frugal), I just put in a switch to turn fans on and off.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #7 ·
I THINK the BCM is behind the passenger side kick panel. If your cowl drains are clogged, the water from the cowl will run inside the fender and down to the connector on the BCM. I'd take a look at the cowl drains, clear them and pull the plug on the BCM and use some CRC Electrical Contact Cleaner on both the pins on the BCM and the connector. Then I'd plug and unplug it a half dozen times in order to help "sweep" the connection clean and retry it. This won't really take that much time and just might help with the door lock and light issues.

Could a issue with BCM cause miscommunication with PCM, and kill ignition?
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #9 ·
Difficult to say if a malfunction with the BCM could trigger engine ignition to turn off and stall vehicle. You would need to connect a scan tool and monitor data PIDS associated with engine operation (crank position sensor, cam position sensor, ignition coil voltage) and see if a sensor signal drops out when the engine stalls.

Carry some starting fluid in your vehicle. Next time stall occurs, remove the hose to the throttle body intake and give a 5 second spray of starting fluid into the throttle body. Engage the starter. If engine starts, runs for 1 - 2 seconds and then dies you know the issue is a fuel delivery problem. If engine does not start and run for a few seconds, then the problem is most likely lack of spark. This test would help narrow down the possibilities.

I'm going to replace crank sensor and fuel filter. Seems those could be a likely fix.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #12 ·
Personally, I hate shotgunning. Most of the time. Especially on this vehicle. Van I'm working on in this thread, is kind of a sh*tbox, I just need it to run, and not stall on me. On my van, I wouldn't feel so bad about loading the parts cannon, my van is a gem, and I like to keep everything in top order. But, I believe that an old and tired Mopar part, is made better and will last longer than any aftermarket part.

That being said..

I put in a new cheap crank sensor, van would not fire. Put old sensor back in, van started immediately. I'm tempted to try an NTK sensor instead, I know that these vans don't like cheap parts.

Again, this is an intermittent problem. Everything seems to function normally, other than the stalling. I presume something is getting hot and shorting/failing momentarily.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #16 ·
If the Cam sensor goes bad the engine will run, but will cause issues. It will stall occasionally while you drive ......
Very possible a cam sensor is all you need. ..... While it works from the computer .... it does not stop the engine from running. Just runs poorly.
If the Crank sensor is bad, it stops the engine from running. ..... Just saying.
A failed cam sensor will cause a long crank time as the PCM determines a substitute cam signal. Cam sensor is the fuel sync (#1 TDC) signal. Crank sensor is the ignition spark & tachometer signal.
Sometimes the tach needle will 'wiggle' while cranking. If the crank sensor has failed, the tach needle sits at 0.
Crank sensors may not set a fault code.

Alternate/OEM Part Number(s): 04727336AB, 4686236, 4727336, 4727336A, 4727336AB

Sounds like I should try an NTK crank sensor. Engine im working on, we'll call it, "turd", starts very quickly, within 3 maybe 4 starter revs. My van actually takes a sec to start, makes me think my crank sensor is getting old..😁

I cannot see any tach needle wiggle, instrument cluster doesn't work.. 😂 Common solder joint issue or bad connection at panel harness I think.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #24 ·
I apologize for being a bit abrupt yesterday with suggesting to just replace it all.

IMHO, I fought the exact same issues for a few years while I was dragging my feet not wanting to learn modern mechanics.
My 1993 caravan would die sometimes when coming to a stop sign .... not always, never while driving .... just when coming to a stop and again not always but more often if the AC was running & engine under a load.
I was trying to troubleshoot many things like the IAC, or I removed the throttle body & cleaned it I was a dog chasing my tail

I eventually found it was a bad cam sensor causing the problem. The engine will run, but will cause some issues like you describe ..... Then next the crank sensor went bad.
When the crank sensor fails, the engine will die & you need to call a tow truck. ..... Last week it was 108 degrees out, I do not want to be sitting for a hour waiting on a tow truck.

Years ago we would do a tuneup on our cars, points, plugs, wires, cap, rotor .... we just replaced it all.

Today we have a crank sensor, cam sensor, coil, wires, plugs. ..... I figure if these parts have enough hours on them that one fails, the rest are not far behind.

It would be nice to determine the exact issue, and if it was a cam sensor like I suspect ... I would check codes to confirm it.
I simply would not change the cam sensor. I would do the shotgun approach & change the whole ignition system at the same time. Avoid future breakdowns on the side of the road.
I honestly think that a 1997 caravan with unknown maintenance .... dies at a stop sign but starts back up ..... a tuneup is not out of the question.

I will be replacing cam and crank sensor with NTK. Van also very likely needs spark plugs, not sure if they have ever been replaced. It needs a lot. The point I am trying to make, is that this van I am working on, is a sh*tbox beater. It also does not belong to me, my father uses it to pick up equipment and such, he is an avid tag saler. He does not care much for it, and does not have much desire to have his van functioning perfectly.

If it develops a miss, I'll have someone do the plugs. It is very difficult to get to the rear of engine to replace them myself. If major issues start stacking up more frequently, we will take it out of commission. He has a 2005 Grand Caravan with low miles on standby. I will take as many parts from it that are viable, for my '97 Grand Voyager, and bring it to scrap. It's a shame to let another old Voyager go to sh*t, my father has never been one to keep his daily cars tip top. Aside from his classics of course.

But just as a testament to the durability of these vans, it is impressive how much they can take, with such little care. I believe it is because they are so simple, even with modern computers. These were the last of real Chryslers, of real quality built cars.
 
1 - 8 of 8 Posts
Top