Allpar Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
ok, i'm picking up a 97 t&c lxi awd today and the current owner says it blows fuses 10, 11, & 12. i've done some searching online and i'm not coming up with anything helpful. i'm hoping the gurus here on Allpar can tell me what i need to know to fix this issue.
 

·
Premium Member
Joined
·
20,074 Posts
Blown fuses are due to a positive wire grounding to body, thus blowing the fuse instead of frying what they are protecting. Has to be some damaged wires so they have to be traced. Look for wiring harness problems to start with, places where they pass through metal panels, animal chew marks, and depending what the fuses are protecting, water entering the harness to cause the shorts or directly on the fuse block. Not much else to say given no history or idea of condition of the vehicle.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
ok, that's a start. from what the current owner tells me it's the turn signals and the front blower motor that are affected, but that only covers 2 of the 3 fuses.
 

·
Premium Member
Joined
·
20,074 Posts
Little animals are known to chew on harnesses every now and then, too, and they are easy to locate the damage.
 

·
Super Moderator
Joined
·
36,916 Posts
Best thing to do is get the factory service manual and use the wiring diagrams in it unless it's obvious from inspecting the wires.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
i'll see what i can do from a visual inspection. i'll probably get a service manual anyway, but i'll see what happens. my motto will be "have electrical tape, will travel"
 
1 - 7 of 7 Posts
Top