Allpar Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi folks just joined the forum I have a bit of a problem. I got a used 98 ram with I believe a 46re
The transmission was rebuilt just before I bought it .
after driving It for about a year I got a code for the governor pressure sensor (dont remember the code any longer).it ran and shifted fine but i needed the check engine light off for inspection. changed the sensor and transducer (as I believe its called) with some out of a junk yard because i could not get one anywhere else.but the check light stayed on and it started shifting poor and seemed to slip on left hand turns.
so last week I put in 2 brand new ones and now its giving me the code p1756 and will not shift past second.i hit 3500rpm for 32mph and it just winds.
It will shift manually from 1st to 2nd and back to drive, but nothing else.
Also I have a p0138 code (o2 sensor) I have read the o2 sensor and gov sensor share the same ground, is it possible a bad ground would cause both of these? Where would I find that ground?
I just removed the speed sensor and cleaned it tonight, it had steel dust on the tip and what looked like antiseze on it *shrugs* drove it ,but no change, I might buy a new one and try that but I don't think thats it.
I really dont think its the gov sensor its the 3rd one I have had in it, and dont wanna put in another $35 in
trannny fluid to drop the pan for nothing, any help would be great...thanks guys!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
I forgot to mention I did try adjusting the tv cable a buncha times. Had it all the way lose ,tight and everywhere in-between, never really seemed to make any difference whatsoever...thanks again
 

·
Super Moderator
Joined
·
21,365 Posts
Dodge:
P1756: Governor pressure not equal to target at 15-20 psi.
The internal metallic debris does not bode well for this rebuild at all. Try to put the kickdown cable adjustment back where it was. You might want to get a service manual that covers the 46RE to go through the 'Possible Causes' of P1756 one by one. A factory wiring diagram manual will also show you the ground locations, diagnostic procedures and information if you are going deeper into this repair.
Governor pressure PSI should track MPH in a 1:1 relationship. The Transmission electronics are handled by the PCM so that Governor pressure and Speed Sensor readout should be available on a good generic OBD II scan tool. If the magnetic speed sensor tip was clotted with iron 'mud', it would not accurately read the transmission output speed. Some vehicles will switch to reading vehicle speed to the ABS sensor if the drivetrain sensor is unavailable.
The scan tool should also tell you what the downstream O2 sensor is actually reading.
Measure line and clutch pressures, loss of 3rd gear and up sounds like something very bad has happened with a clutch (i.e.- front clutch) and that is what is left in the pan.
Generally a rebuild warranty covers a 1 yr/12K mile period.

http://www.scribd.com/doc/46005255/46RE-Service-Manual
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thanks imperialcrown I am looking to install a permanent transmission oil pressure gauge, first I need to find one! Not sure they even make them.I would agree there might be a bigger problem but the transmission was fine untill I changed the gov sensor, and when I changed it again it got worse.i feel as if theres a bad sensor somewhere or something else wrong.i am going to try to borrow a better obd2 tester I dont think mine will tell me anything but codes (its a cheapy) but I will try it in a bit anyhow.
I think I am going to like this place I now have 2 dodges and plan on doing alot more work lol. And I dont think the tranny in my truck will give me a choice.
Any other advice , tips and possibilities from anyone would be great...Thanks!!!
 
1 - 4 of 4 Posts
Top