Allpar Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter #1
98 Sebring conv with the 2.5 six cyl. Man, I sure hope someone knows why this car keeps stalling out when you come to a stop and what to do to fix it. Heres what has been done: mass air flow sensor, map sensor, changed distributor, changed distributor cap, changed plugs and plug wires, o2 sensor, plentum gasket, intake gasket. Now the mechanic is saying the reason its misfiring is the catalytic convertor. It just seems like cat wouldnt cause the problem. When you drive it, as long as you keep the foot on the pedal it seems to run fine, like you cant tell its missing. But when you stop it idles down like its about to shut off. Any advice on where to start from here? Like what could be next, then if that dont work maybe whats next after that. I will do whatever you all advise until its fixed. And as always, THANKS a LOT!!
 

·
Registered
Joined
·
181 Posts
It sounds like what was happening to my LeBaron 3.0L. It turned out to be dirty throttle body not getting enough air to AIS at idle.
 

·
Registered
Joined
·
3,689 Posts
Hahaha - take it form me, it's in the ASD circuit.

I do own one of these, and have had this issue a few times. It's either the Cam Position Sensor (CMS), the Crank Position Sensor (CPS), or the coil itself that is causing the issue.

It is most likely the CPS, 2nd most likely the CMS, and least likely the coil. (Even though you've replaced them, unless they were replaced with Mopar parts, they are still a culprit. Ask me how I know...)

The CMS is in the distributor, and so is the coil, so start by looking at the CPS, if that doesn't fix the issue, replace the distributor.

These cars monitor the cam and crank timing constantly, for many reasons, and if they are not in-sync, the PCM shuts the car down via the ASD realy. It kills fuel to the injectors.

When the ASD engages, no Check Engine Light (CEL) or code is triggered.

If you want, I can walk you through the diagnostic procedure, though you'll need a few things before we start.
 

·
Super Moderator
Joined
·
21,351 Posts
I agree with what's been said so far, but your technician must have a reason for suspecting the cat. You mention misfiring, is it setting misfire codes?
If the cat is breaking up and plugging the exhaust exit, it can do exactly what you are describing at low speeds and idle. This blockage can be intermittent. Does it ever cut-out at road speed?
It can take a few days to set a P0420 (cat efficiency) fault code as the PCM has to run and pass all the other O2 and EGR tests first before testing the cat. The cat monitor test passes last. The fuel tank has to be above a 1/4 tank to run the self-tests.
Changing the sensors with non-OEM parts can lead to the same failure again. This makes diagnosis more difficult as one does not suspect a new part as being bad and looks at something else as being the problem.
The early Mitsubishi distributors were a problem on the 2.5L and a used one is no guarantee that it is a good one. Even reman units can go through the reman process and go back into a car and still have problems. These can be intermittent which makes them even harder to catch or fault. It's nice when they just flat-out quit as that makes diagnosis and locating the trouble fairly easy. Make sure that the distributor connections are secure as I have found broken plastic retainers, missing clips and partially plugged-in connectors here.
A road test with a scan tool showing CMP and CKP sensors as being present while running is most useful as diagnosis. The moment that the car quits, see which sensor was lost or undefined first. Of course after the stall and the engine stops turning completely, both signals will be lost.
As the distributor (CMP) problem was cleared up, it seemed that the CKP sensor was the one that failed more often.
An out-of-sync issue can be caused by a skipped timing belt. The belt, idler bearing and water pump should be serviced at ~100k miles as a matter of maintenance. The distributor position is not adjustable.
 

·
Registered
Joined
·
160 Posts
Discussion Starter #6
And again, ya'll nailed it. i'll be starting on it tomorrow. Cam position sensor 1st. Do you think I should replace the distributor again then while its out for the cps? Man i cant wait to start fixing this. You guys are the best. Let ya know whats going on after new cps is installed. I will get the codes if any with my obd2 as well tomorrow. I let someone use it, getting it back tomorrow. Imperial always says the same thing doesnt he? "WHATS CODES ARE YOU GETTING". I shouldve known to have fault codes with the 1st post. Sorry Imperial C, forgot. But yea, Will def get ya the codes tomorrow and go from there. Thanks!
 

·
Registered
Joined
·
3,689 Posts
Whoa, whoa, whoa - you're bypassing the Crank Positioning Sensor as an issue? This is not advisable. Diagnose it first before jumping to the CMS.

FYI, if the CPS or CMS has an intermitent failure, the car will backfire or knock badly, possibly causing the CEL to flash during the episode, indicating a cat-harming knock or backfire. This can also cause a cat-related CEL to occur, but this is simply an after-effect rather than the cause.

You can very, very easily diagnose the proper function of the CPS with just a simple voltmeter and a hairdryer. If you want, I can walk you through it. The CPS is most usually the culprit in these cases, and is far cheaper to replace than the distributor.
 

·
Registered
Joined
·
4 Posts
I have had similiar problems w/ my '00 Sebring 'vert. I replaced the crankshaft position sensor and that stopped the stalling and chugging issues. I've just had a similiar issue re-occur and I replaced the fuel filter,distributor (w/ the sensor built into the module itself), and spark plugs. The fuel filter weighed a ton due to build-up. I check out issues on www.sebringclub.net to see if others have had the same problems. My mechanic laughs, but I want some idea of what it may be and I also try and replace the parts w/ ones w/ a better and longer warranty to avoid further expenses for me since I'm on a fixed income. It works for me....
 

·
Registered
Joined
·
160 Posts
Discussion Starter #9
Yea, Jerry is correct. I wasnt thinking. I agree 100% about dont bypass the crank positioning sensor! It was replaced, problem seems fixed! I waited for a couple days to make sure before I posted it but the problem with stalling seems to have disappeared. Girls and guys, trust me when I say that Imperial, Simick and everyone else in Allpar def knows a thing or two. Were fortunate to have all ya'll, everybody that participates sharing their knowledge. Ive fixed several issues because you guys, girls, have relayed your input and saved several dollars as well. Lots of those dollars! Well, ok, cps sensor seems to have fixed this one. Can anyone tell me the right way to mark this post as "solved"? Oh yea, thanks!
 

·
Registered
Joined
·
3,689 Posts
Glad you got it fixed. I love my Sebring, but the electrical system really is annoying and troublesome...

Also, SebringClub.net is a great resource for 'vert owners. You'll find me on there as "69RoadRunner."


TAZMO, if the car is stalling, and there aren't any codes, there are only 4 things I would check. (Bear in mind, new parts don't nessicarily mean they can't be the culprit.)

1) Check the negative battery post connection on the inner fender. There are actually two nuts on this post. Remove the upper nut and wiring connector, check the tightness of the lower nut, then replace the upper connector and nut.

2) Check the operation of the ASD relay.

3) Check the Crank Positioning Sensor.

4) Check the distributor (Cam Position Sensor and coil)
 
1 - 10 of 10 Posts
Top