Allpar Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
606 Posts
Discussion Starter · #1 ·
My 3.0L has been repoting. p 0300, p0304 and 305 misfires. Also... blows blue on start up....but appears not to consume oil. Currently 265, 000 km. I replaced all worn plugs that were over .070". Also new wires.cap and rotor with platinum plugs gapped to original spec.
Engine still throws 0300 and 0304. Coolant level remains constant and no moisture in oil.

Your thoughts? Coil? Valve gudes . Valve seating. Injector. Carbon build up?
 

·
Registered
Joined
·
606 Posts
Discussion Starter · #4 ·
John Wood said:
I just replaced the EGR valve on my 96. .0 due to occasional sticking (I believe). Does your van miss at higher speeds,... or only at idle?
Mine actually coughed once with low power when I was pulling away from a rest stop on the Interstate. It ran and still runs perfect at highway speeds. I changed the original EGR valve that lasted 218,000 miles. The passageways were not clogged with carbon.
The engine doesn't miss at hwy speeds....just idles unevenly at 700 rpm and reports P304 on cyl 4... and you know that it sounds as if one valve isn't seating. Sure wish this was a 2.5.... instead of the 3.0L, due to ease of access to cyl. heads and other components.


The spark plugs I just put in were Bosch platinum. @ 1.lmm gap. One thing I forgot to mention was it is quite clicky ( Valve lifters I presume) ... until it warms up....most likely head issue. If it weren't such a pain to pull these heads off after compression testing,I would do just that


I. Recently saw a 99 GC @ 3.0 in mint condition but worn trans. Now... if only my. A670 was compatible along with the 1999 computers software I would simply go and make the swap what a pain
 

·
Registered
Joined
·
606 Posts
Discussion Starter · #7 ·
The BOSCH platinums were on a promotion for the same price as the OEM Champion.... so I decided to give them a try.

P0300 was originally set following P0304... so Cyl 4 on this 3.0L is the offending one.
ImperialCrown said:
A cranking Compression test may not show a leak, where a static compression leak-down test would.
Bosch plugs have had issues in these. You will see a side-by-side difference with tip shape/depth (heat range) compared the the correct Champion plug.
Has it settled on cylinder #4 as the misfire choice?
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top