Allpar Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

First time poster, long time google lurker

I have a 1996 Dodge Grand Caravan LE. I've recently tried replacing the blower motor resistor after years of trying to figure out why the fan was only on high all the time (even a Mopar mechanic "friend" couldn't figure out why the problem exisisted, he suggested I change out the HVAC control panel).

I purchased a new resistor and pulled it out of the firewall. The resistor was all rusted/corroded. One of the male parts of the resistor corroded or melted into the old female connector portion of the plug harness. Now instead of only high speed fan, I have no speed fan.

Any idea where to get a replacement part for the plug connector harness? Is a junk yard my only option?. I've looked on ebay to no avail. See pic below of connector/plug in question.

Any clues/help would be much appreciated. tia.

 

·
Registered
Joined
·
11,098 Posts
I had the same thing happen to my 1996 mini. I got the pigtail from an online dealer, cut the old one off and soldered in a new plug. If you don't want to use a dealer, NAPA can usually order pigtails for you but they often cost as much as getting it from the dealer. I should have some pictures in my collection and probably have the part#. Check back here in a short while and I'll add those pictures to this post when I find them.

Here are some pictures:



 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
That is very cool John Wood and ImperialCrown...Thanks so much!. Ordering it right now. Thanks much! (Not sure why I couldn't find it on Ebay. Very strange).
 

·
Registered
Joined
·
11,098 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #6
1 - 6 of 6 Posts
Top