Allpar Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I have a 2004 dodge stratus with a 2.7L v6 multi port fuel injection. The car will run fine for a week to 3 weeks then all of a sudden you will shut it off to go in somewhere and when you come back it will start and die start and die over and over i have to let the car sit for up to a day before it will start and stay running and then it will run for another week or so then do the same thing. I have changed the fuel pump and the map sensor i was wondering if anyone had any ideas what this could posibly be it would be much helpful
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
also sometimes when you get it moving when it wants to die it will somewhat come out of it but it keeps running down the road as long as you dont have to stop and it seem to run fine after that
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
the fuel pump was making all kinds of weird noises and the car was acting like it wasnt getting any fuel a tech at the dodge dealer said it was goin out and the filter and the pump were all one unit. the map sensor was the first thing that i replaced when the car started acting up but that was bofore the fuel pump went out. when i replaced the fuel pump the car ran great for about three weeks i thought it was fixed but then it started doin it again and it was about 95 degrees that day. is there an in line fuel filter either on the under body or under the hood at the parts store they told me there wasnt thanks for the help
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
i was the one who changed the fuel pump and i drained the tank to see if there was anything floating around in the tank and put new gas in thinking that could be it is there anything you could recamend that would clean the injectors with out removing them or should i pull them to clean them. is this something that could happen when it gets hot out
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
ok i will add some and i will pull some injectors tomorrow and see what i got. is there any way this could be a ground problem this is what a few people have thought it might be and i would like to get another apinion on it. there was something making a whistling noise coming from under the hood after the last time that it happened (my wife just informed me of this) any idea what this is or if this could be causing it
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
well injectors that pulled all looked good and clean i dont have the things i need to check fuel pressure now but the car is running fine now and i cant get it to act up i checked for vacuum leaks with spray and checked hoses cant find any bad ones but im going to recheck here in a while do u know of any certain ground that might be causing this i also checked all wire connections that i could find
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top