Allpar Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 47 Windsor that's 6 volt positive ground. I bought a universal door jamb switch for the front pass. door. There are two wires behind the kick panel that weren't hooked up to anything. After touching one wire to the only connection on the switch, the other to the body of the switch, it worked. Pushed the button, light goes on and off.....great.
Now I install the switch (one wire to the connection, the other to the body of the switch) by screwing it in the little hole provided in the body and the wires heat up, light doesn't work, there's a ticking sound from somewhere. I jump out and disconnect the battery.
Now what? What am I doing wrong?
Thanks
Wayne
 

·
Super Moderator
Joined
·
21,365 Posts
Warm wires indicate excessive current flow. Is one wire a power wire that is being grounded to the car body by the universal switch instead of passing through like on the original switch?
 

·
Registered
Joined
·
6,042 Posts
I suspect that the one wire is the hot wire and the other wire goes to the light which is grounded at the light. Original switch took the hot wire on one side and then through the switch to the wire going to the light and to ground there. That would explain it working with the switch not mounted as the new switch connects the terminal to the ground side of the switch. When mounted, you have a direct short with a one terminal switch. You need a two terminal switch that does not connect to ground at the switch. Ticking sound would be a circuit breaker opening and protecting the wiring. Later cars use a one terminal switch that grounds at the door and not at the light. If you cannot find a two terminal switch, you would have to modify the light to a non-grounding light and snake another wire back out to the one terminal switch and ground it and connect the existing two wires together. (Not a great option.)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Thanks for the replies. Yes, I think I bought the wrong switch. Searching on line, I found a two connector door jamb switch.
This neg ground, 6 volt stuff sure has me scratching my head. I'll let you know when I get the new switch and hook it up.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Got the new switch, installed it and it works. Everything looked good until I left the door open too long. The wires got hot and started to smoke. Disconnected everything. It's not meant to be.
 

·
Super Moderator
Joined
·
21,365 Posts
There may still be too much current draw. Do the lamp(s) light brightly when it works? What amps is the switch rated for? How many interior bulbs are lit and are they the correct bulb type?
If you remove the bulb(s) and disconnect the battery, measure the lamp feed side wire resistance-to-ground. It should be close to infinite ohms.
You may have a wire rubbed through at a bend and shorting to ground (wire insulation cut on sharp edge or shorted socket itself) or someone may have added something to the circuit that is drawing too much current. Sometimes the old cloth wire insulation rots and crumbles off, leaving a bare wire that can short to body ground.
 
1 - 6 of 6 Posts
Top