Allpar Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I just installed a new auto meter tach. In my 75 dart 318 se went to start it no power redid battery twice finally got it to crank but it won't hit. So I check positive voltagage at the coil which registered at 5.7 so I run full battery power to coil still won't hit. And the coil wire is brand new and has good continiuty, coil has good ground. New cap and rotor, it is getting fuel and finally the coil ohms out good and has good continiuty from+-..... any other ideas that this problem could be????????
 

·
Super Moderator
Joined
·
31,983 Posts
How did you hook up the tach, to what connections underhood? Should be between negative coil connection and ground.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Negative terminal on the coil a ground on the dash and light on anaccessory terminal on a new light switch I have
 

·
Super Moderator
Joined
·
31,983 Posts
"went to start it no power redid battery twice finally got it to crank but it won't hit"

Back to basics. Your battery connection was no good at first. Check the cables where the insulation meets the clamps, make sure all is clean and intact.

Then measure battery voltage with engine off, and while cranking. While cranking, should be about 10.5 volts or higher, should not fall below 9.5V. If it does, put it on a charger and when topped off, repeat. If still low, replace battery.
 
  • Like
Reactions: 75devil

·
Registered
Joined
·
39 Posts
Discussion Starter #5
I finally got it running it turns out when I reconnected the coil I pooped the ballast resistor. Why I had not thought of this before idk... thank you for the help though
 
1 - 5 of 5 Posts
Top