Allpar Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
When I push in the cc button, the CRUISE light comes on, then goes off. It will not come back on until I turn off the car then turn it back on, with the same result. I have switched out the brake switch and the same thing happens. Any suggestions would be appreciated. Thank you.
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
22,725 Posts
Any stored PCM fault codes after the CRUISE light goes out?
A capable scan tool that can show switch states may help determine why CC is being disabled.
I've seen a sticking steering wheel switch or open clockspring issues cause a disabled CC.
The PCM won't allow CC operation if it feels that it could be unsafe.
 
  • Like
Reactions: AllanC

·
Registered
Joined
·
5,064 Posts
. . . . When I push in the cc button, the CRUISE light comes on, then goes off. It will not come back on until I turn off the car then turn it back on, with the same result. . . .
Do you have other diagnostic codes such as P0581, P0582, P0586, or P0594? These are codes associated with abnormalities in the speed control switch circuits and vacuum, vent and solenoid control of the control servo. If any circuit problems are detected the PCM will NOT allow the speed control mechanism to be activated. This is a manufacturers safety design to preclude any possibility of run-a-way throttle on the vehicle.

If you have no other specific speed control codes then the system is sensing excessive resistance in a speed control circuit and disabling the speed control operation as noted. Disconnect the battery cable. Remove connector C3 at the PCM. Carefully clean the pins and mating receptacles at pin locations #5, #7, #12. These pins and receptacles will look satisfactory but clean accordingly. See attached images.

Text Font Line Parallel



I had the exact problem you describe on a 2003 Neon speed control system. Start the engine and start forward motion. Push cruise control button and momentary engagement and then system shut down. I removed connector C3 and cleaned the pins. Problem resolved.
 

·
Official Mopar Reps
Joined
·
58 Posts
When I push in the cc button, the CRUISE light comes on, then goes off. It will not come back on until I turn off the car then turn it back on, with the same result. I have switched out the brake switch and the same thing happens. Any suggestions would be appreciated. Thank you.
We'd be happy to look into this further with you, rhensonsr. To clarify, have you had the chance to visit a certified FCA dealer to have this addressed? If not, our team is happy to connect you with your favorite one for an appointment. To start, send us a private message with more details.

Kate
MoparCares
 

·
Super Moderator
Joined
·
32,835 Posts
You changed out the brake switch, but did you adjust it?
 
1 - 7 of 7 Posts
Top