Allpar Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
782 Posts
Discussion Starter · #1 ·
I had new struts put on the front of my 16 Dart GT a couple months ago and now notice a popping sound coming from the right front when I turn the car at low speed. It has never made that noise prior to getting the struts replaced.
Answers?
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
22,488 Posts
Does it do it at a standstill in Park (or Neutral with the parking brake on)? Pop the hood, place you hand on the top of the strut tower and feel for the popping noise.
Possibly upper mount bearings or the spring rubbing on sheetmetal inside the tower?
 
  • Like
Reactions: AmbassadorSST

·
Registered
Joined
·
782 Posts
Discussion Starter · #3 ·
Does it do it at a standstill in Park (or Neutral with the parking brake on)? Pop the hood, place you hand on the top of the strut tower and feel for the popping noise.
Possibly upper mount bearings or the spring rubbing on sheetmetal inside the tower?
It does it when I turn the wheels at low speed...like when you turn the car around in a parking lot, when the wheels are turned the most.

I'll have to try that tomorrow. Thanks for the response.
 

·
Registered
Joined
·
8,695 Posts
Were those quick strut assemblies or new struts on your old springs and bushings? If the latter, I'd have to agree with IC that is sounds like a mount bearing. I suspect the reused the old ones and didn't put in new ones, like they should have. Another remote possibility is the half-shaft. Pretty coincidental if that's the case and I don't believe in coincidence.
 

·
Registered
Joined
·
782 Posts
Discussion Starter · #5 ·
Were those quick strut assemblies or new struts on your old springs and bushings? If the latter, I'd have to agree with IC that is sounds like a mount bearing. I suspect the reused the old ones and didn't put in new ones, like they should have. Another remote possibility is the half-shaft. Pretty coincidental if that's the case and I don't believe in coincidence.
Just the new struts on the old springs and bushings.
 

·
Registered
Joined
·
3,911 Posts
I had that noise on my old 97 caravan.
Was a bad sway bar link.
 

·
Registered
Joined
·
8,695 Posts
Yep, they'll make noise too. I'd still have them check the upper mount bearing.
 
1 - 8 of 8 Posts
Top