Allpar Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter · #1 ·
Oil Pressure Sender DIY

I googled this work and those pro’s used a lift for this and were able to stand up and reach in which doesn’t work so good when I laid under the car. So I used a different approach while standing with the hood open.

First I got the filter assembly and battery out of my way. Then I loosened/removed the 2 bolts holding the fuse blocker block and wedged it out down and out of my way.

Peeking behind the engine, you can see the connector which has a red lock tab that has to be pushed into the connector only then can the thumb tab can be levered and the connector pulled directly rearward.

I had to use a flex-joint on the 27mm socket to allow me to get my shorty ratchet in place which meant it was harder to get the sensor loose. I wrapped the new sensor with 1 wrap of thread tape and reversed the above. Remembering to flick the red lock tab back on the connector after it snaps into position.

Since my battery was pulled, my #0522 Check Engine Light (CEL) no longer was registered in the fault memory of the engine’s computer.

I have some pictures of this work, feel free to contact me if you need visual re-enforcement.


Mister2 TIM
SupercharZed ToyZ RacZing
Boca Raton, Florida
 

·
Virginia Gentleman
Joined
·
16,163 Posts
Might help if we knew what year, make, model and engine this was for.

I had to replace the oil pressure sensor on a 2.5L 4 cylinder engine, but it was relatively easy to access since it was on the front of the engine.
 

·
Super Moderator
Joined
·
33,508 Posts
Oil Pressure Sender DIY

I googled this work and those pro’s used a lift for this and were able to stand up and reach in which doesn’t work so good when I laid under the car. So I used a different approach while standing with the hood open.

First I got the filter assembly and battery out of my way. Then I loosened/removed the 2 bolts holding the fuse blocker block and wedged it out down and out of my way.

Peeking behind the engine, you can see the connector which has a red lock tab that has to be pushed into the connector only then can the thumb tab can be levered and the connector pulled directly rearward.

I had to use a flex-joint on the 27mm socket to allow me to get my shorty ratchet in place which meant it was harder to get the sensor loose. I wrapped the new sensor with 1 wrap of thread tape and reversed the above. Remembering to flick the red lock tab back on the connector after it snaps into position.

Since my battery was pulled, my #0522 Check Engine Light (CEL) no longer was registered in the fault memory of the engine’s computer.

I have some pictures of this work, feel free to contact me if you need visual re-enforcement.


Mister2 TIM
SupercharZed ToyZ RacZing
Boca Raton, Florida
If that's a 1-wire sensor, not a good idea to wrap the threads. They serve as the ground connection, and wrapping them will partially or totally isolate the ground connection, throwing off the sensor reading. Oil pressure sensors are tapered and are made to screw in tightly enough to prevent leaks.
 

·
Registered
Joined
·
1,291 Posts
Bob; I've had good luck using the thin teflon tape over the years. On 1/8" NPT brass fittings the shiny brass is still visible on the threads after tightening and removing. So I strip off the old tape and put on new. And on water systems, it aids in removal after several years.
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,850 Posts
Teflon tape is a great idea if the sensor doesn't rely on the sensor screw threads as a ground connection.
 
  • Like
Reactions: Bob Lincoln

·
Registered
Joined
·
159 Posts
Discussion Starter · #6 ·
If that's a 1-wire sensor, not a good idea to wrap the threads. They serve as the ground connection, and wrapping them will partially or totally isolate the ground connection, throwing off the sensor reading. Oil pressure sensors are tapered and are made to screw in tightly enough to prevent leaks.
----------------------------------------
Hi Bob, if you read carefully enuff you would have seen this "I wrapped the new sensor with 1 wrap of thread tape".

Is that Avatar picture the Daytona Turbo from years ago?
 

·
Super Moderator
Joined
·
33,508 Posts
----------------------------------------
Hi Bob, if you read carefully enuff you would have seen this "I wrapped the new sensor with 1 wrap of thread tape".

Is that Avatar picture the Daytona Turbo from years ago?
I did read carefully. You put one wrap of tape around the threads. That can partially insulate a 1-wire sensor and throw off the reading somewhat.

That is my 84 Daytona Turbo Z, which I've had since 2008. The 93 rusted out too badly to keep. Yet the buyer, who was explicitly told of the safety risk and parts-only status, chose to put it back on the road in upstate NY.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top