Allpar Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Gang,

my problem is that my engine shuts down when I push in the clutch to slow down as I approach a stop light/sign etc. when i take off from a stop, everything works fine. if i am accellerating and going thru the gears (like when you pull away from a stop light) it works just fine. but as soon as I let off the gas and begin slowing down, if I push in the clutch the motor cuts out. you can kinda "trick" it by constantly putting it in neutral after you climb to your cruising speed. so what ive been doing is accellerate thru the first few gears until i reach my cruising speed and then shifti into neut and coast for a while. if i need to accellerate more i put it in 3rd or 4th, accelleate and then shift it back into neut again and coast. rinse and repeat.. by driving it this way, it will allow you to push in the clutch when you need to slow to a stop. but u have to be coasting for a period of time (until the engine returns to idle speed) before you can push in the clutch. if you don't it shuts down.

i just did a tranny swap (nv3500). it was from a newer year so where the VSS was supposed to mount (on tailshaft of tranny) that port was capped so i don't have a speed sensor working. do you think this might be why the engine shuts down? or would you say it could be the crank sensor got hosed when I dropped the old tranny? Or? ABS?

thanks
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Sorry guys, after that big old shpeal, i forgot to mention make n model... 96 ram 1500 sport with the 5.2L, 2WD.

Imperial Crown, thanks for your insight. I had a feeling the PCM was looking for a value from VSS before it can respond/send a value to the Idol Air Control. That was really the only thing that changed during the swap. So you say that the speed sensor CAN be joined with the ABS in the rearend? I'm hoping there is some kind of fix like this available because i'm pretty much stuck with this new tranny and cant afford to replace it. I posted that very question on some other forums and got some mixed responses. Seems to me like it can be done. I was told the tranny was from a 2001 which still put me in the 2nd Gen Ram's so I thought it would work since mine is a 96. But then later read that in 2001 they sent the VSS back to the rearend to join with the ABS. Is that correct? If you have some more info on how I can make this modification I'd sure appreciate it. I have the tranny out right now. I was trying to remove the cap on the tailshaft to see if that speedo gear was even in the tranny and its not so I'm about to weld another cap on it and get it back in the truck as I need to use it over the holiday weekend.

At one point I thought it could be the Crank Pos Sensor because I read in the manual that if you drop the tranny without first disconnecting the CPS, that you can hose the CPS. I tested the sensor and got an open reading on the OHM meter so I think I can eliminate that as a possibility. Although it was covered in oil when I removed it. Let me know what you think about that as a possibility. Cuz it feels like somewhere in there ASD is being triggered cuz this thing just goes dead. Sometimes if I catch it quick enough I can chop the throttle after pushing in the clutch and save it from dying but that requires reving the engine intermittently as i'm braking and coming to a stop. Not ideal but it works. When this thing cuts out its hard to control with no brake pressure and no power steering. If it cuts out rounding a corner... Look out!

Thanks again,
Shane
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I have the speed sensor from the old tranny and the reverse light sensor, etc. but as for the hard parts and the tranny itself, no I don't have it or access to it.

okay good, so It sounds like I can eliminate CPS.

So how would I set this up then? Do I need to replace the ABS sensor with newer one? One from the same year as the tranny, presumably (2001)? Could you describe in a little more detail how you would resolve the issue? I'm fairly savvy around the "wheels" and am also a programmer so I understand computer systems, just have never applied it to reprogramming ECM's or PCM's.

Thanks again
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top