Allpar Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
609 Posts
Discussion Starter #1
So here's my problem;
I lent my car out last weekend to a friend and he called me and said that the 'tona just stopped running while it was in fifth gear as he was driving on base.
My buddies and I towed it back to our parking lot and I am just dumbfounded.
When you put the key in the "on" position you cannot hear the fuel pump prime and when you try to start it, there is either no spark or no fuel. I can't tell which.
A few months ago I had the same issue and a new HEP fixed it, I had another spare lying around just in case but still no dice when I swapped it out.
The only other thing I've checked is the timing belt and it is a-ok.
So as of now I'm lost so any help you guys can give me would be great!


-Mike
 

·
Super Moderator
Joined
·
31,984 Posts
You should hear the fuel pump prime for just 1-2 seconds when you turn the key to ON. You can do that twice in a row without cranking, and then the 3rd time, it will not run until you crank it.

You can also check fuel pressure by unscrewing the cap on the Schrader valve on the fuel injection rail, and on a COLD engine, press the pin and see if you get any fuel. It should give a a quick spray (watch your eyes!). If it has nothing, or just a small dribble, the fuel pump is very likely dead.

Mine died last year on the highway with no warning at all, just shut off at 65 mph and coasted to the breakdown lane. It was 28 years old and something like 125K miles on it. I installed a Bosch pump from Rockauto for $186, because the cheap one are noted for failing early.
 

·
Registered
Joined
·
609 Posts
Discussion Starter #3
Well upon further testing I don't think it's the fuel pump. It's less than a year old and it's one of the high-flow Walbro units.
Additionally, I tried testing the ignition coil by holding it close to a ground and it's not producing any spark. I replaced it with a BWD unit from Advanced, but it still isn't getting anything.
 

·
Registered
Joined
·
8,043 Posts
Probably a stupid question, but have you checked all of your fuses in the fuse box. I don't recall, but there may be one for the ignition.
 

·
Registered
Joined
·
294 Posts
Well upon further testing I don't think it's the fuel pump. It's less than a year old and it's one of the high-flow Walbro units.
Additionally, I tried testing the ignition coil by holding it close to a ground and it's not producing any spark. I replaced it with a BWD unit from Advanced, but it still isn't getting anything.
Have you changed the ignition wires? You might have a bad hi-tension wire. In any case I'd get new wires if you have done so already.
 

·
Registered
Joined
·
609 Posts
Discussion Starter #6
Would no spark to the distributor cause the fuel pump to not run?
 

·
Registered
Joined
·
24 Posts
did you try starting fluid yet? to test for spark i remove the plug and put it onto a good ground source to check it..
Unfortunately fuel pumps regardless of brand, will just eventually quit! I would check to see if there is power to the fuel pump and the coil.
When was the last time you changed the fuel filter? any blockage there will give many issues , Bad gas can also happen at any station..

Spark would come from the coil into the distributor cap then to the plug, Spark is controlled from the module inside the distributor..Did you check the cap (inside)for corrosion?
 

·
Super Moderator
Joined
·
31,984 Posts
Before replacing anything else, do more diagnostics. Check fault codes always, first.

And what test did you do to determine that the fuel pump is OK? You say it still doesn't run at all?

When was the last tuneup - how many miles and what time interval? (Especially the ignition rotor - these cars eat them every 15K miles).
 

·
Registered
Joined
·
451 Posts
Almost sounds like it's not getting a signal to try and crank over at all. Look for the easy stuff: loose connection, fuse, etc.

Bob L. - Not sure that I'd say they eat them that often. I've never changed the one on the '92, and it still fires every time. I think it's just a possessed car though.
 

·
Super Moderator
Joined
·
31,984 Posts
I've owned these 4 of these cars over a 27 year span and a total of over 530K miles. The rotor has always been charred on all of them at the 15K interval at which I tune them. On one car, I had a sudden no-start that plagued me for 2 days, until my spark tester showed a very weak spark from the distributor. I replaced the rotor and it started instantly and ran like new. I had let it go 20K miles. It's cheap insurance to replace them at regular intervals.
 

·
Registered
Joined
·
41 Posts
i had a similar problem with mine. no fuel pump prime and what not so we replaced that. still nothing so we took it to my uncle and he determined it was the throttle position sensor ground wire. so you could try testing your grounds.
 

·
Super Moderator
Joined
·
31,984 Posts
Always good to check all the grounds. That particular instance would trip a TPS code, as loss of its ground would cause the signal to go too high.

Mike, check the braided ground strap from firewall to intake manifold. Loss of that ground would cause a no-start, it's the ground for the fuel injectors.
 

·
Registered
Joined
·
11,098 Posts
Just a simple question. Did you verify that the distributor rotor is actually turning when the engine is being cranked?

If not, the usual problem is teeth sheared from the timing belt (I know you said you checked it but it could still be intact). I read at least 1 post here where a guy had his intermediate shaft break (timing belt was good, but distributor rotor not turning).
 

·
Registered
Joined
·
609 Posts
Discussion Starter #14
I checked the Shelby again this morning and it gave me a code 54. I know that is for the HEP, but I just replaced it and that didn't solve the issue before.
I'm going to go look at it again later this afternoon. I hope it's not the intermediate shaft because after a brief search on the web it doesn't look like anyone makes a replacement.
 

·
Super Moderator
Joined
·
31,984 Posts
If the HEP is bad (and the replacement one could be, or the harness connection), the ASD relay will open and the fuel pump will then not run. However, starting from key OFF, turn ignition to ON and listen. Fuel pump should still run for 1-2 seconds, even if HEP is bad. Does it? If not, fuel pump or the power path to it is bad.

Do you have the right HEP? Some , like my 84, have the two sensors, one on top and one on bottom of the plate. Make sure what you have in there matches what was in there when the car worked. Make sure the electrical plugs are fully seated and connected to the proper pair.
 

·
Registered
Joined
·
609 Posts
Discussion Starter #16
Well, turns out the "new" HEP is defective. I took the ground off of the diagnostic connector to deactivate the ASD and low and behold the coil had power. I knew this because I had a test lamp. When the HEP was active the coil was not getting any power. I then jiggled the wires around a bit on the HEP and the Shelby would try to start, but couldn't since the HEP wasn't getting a solid connection.
I just said screw it and spent the $40 to get hopefully a good unit from advance.
 

·
Registered
Joined
·
609 Posts
Discussion Starter #17
The new HEP arrived at Advance yesterday and wala! The Shelby Z is now purring like a kitten, an angry kitten with no cat or muffler lol!
 

·
Registered
Joined
·
609 Posts
Discussion Starter #19
The HEP I got from Advance has a lifetime warranty on it, but an extra one just in case won't hurt!
 
1 - 19 of 19 Posts
Top