Allpar Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Have a 2008 dodge avenger with remote start and keyless entry that won’t work, have two key sets and both wont start or lock car… have replaced batteries in keys. Took to dodge dealer, they checked signal strength of key, cked ok. They insist to buy new key [cost of $220.00] two key sets bad? There’s got to be something else wrong. Looking for any other ideas.
Thanks tom
 

·
Super Moderator
Joined
·
21,365 Posts
Welcome to Allpar. Any 'ck eng' symbol or red dot illuminated on the instrument cluster (security system) or other warning lights/messages?
There may be fault codes stored that would help here. Fault codes may show in the odometer or EVIC (if equipped) display. To initiate the self-test, hold in the odometer reset button while rolling the ign key on. Write down any fault codes that may appear in the display.
The key signal strength may be fine, but without the car at the shop they can't diagnose it any further. You may need to have it towed.
 

·
Registered
Joined
·
8,747 Posts
Sounds like a problem with the immobilizer/SKIM reader?
 

·
Moderator
Joined
·
3,813 Posts
Sounds like you may just try and get your current keys programmed again, although they might not be able to do that on that model year, I can't remember anymore. Does the alarm on your vehicle go off when you unlock the door using the key?
 

·
Registered
Joined
·
2 Posts
Pull the iod fuse to reset the Wireless Control Module. Most likely incurred a static shock and replacement of the module will prevent this from happening again. There is a tsb on this issue.
 
1 - 7 of 7 Posts
Top