Allpar Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Ok, just took my '84 Omni (2.2l carb, 3-spd auto) through NJ inspection and failed the high-idle test:

Standing Idle:
HC ppm 28 (220 allowed)
CO% 0.53 (1.20 allowed)
CO2% 14.3
O2% 0.9


High Idle:
HC ppm 88 (220 allowed)
CO% 4.65 (1.20 allowed)
CO2% 12.1
O2% 0.2

All the secondary tests passed (even the original gas cap still passes!), but the High-idle CO is the issue.

I could have sworn I'd be able to search up some troublehsooting threads for this, but apparently my search-fu is lacking today. Can I get a point in the right direction?

Thanks,

Rob
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
Thanks for the quick response - that was an interesting read.

What caught my eye was that it mentioned specifically that high CO at only high RPMs could be indicative of a clogged/restricted air filter. Since it's been a couple years since I changed that and the car isn't driven regularly (not to mention I once opened the hood and a mouse dropped out of the hood blanket, shot me a dirty look, and took off), I guess I'll run down the local Wal-Mart tonight and pick one up. it's a cheap thing to try first, if nothing else.
 

·
Premium Member
Joined
·
20,074 Posts
Well, given all your numbers are borderline, a full tune-up may be in order, then run it hard to clean it out a bit might help.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #5
Those numbers are borderline? I thought they all looked pretty good except the one that failed. NJ doens't have spec limits on CO2 or O2. Can you explain a little more on what you're seeing that I'm not?

Funny thing is it got a good hard run yesterday (a couple hours of driving to get to a place that had tires for 13-inch rims - not easy these days), and then I had a caliper start to lock up on the way down to inspection and finally freeze for good while waiting in line at the inspection station. Had to have it towed out and got it fixed, then ran it back down this morning - about 25 minutes of 50-55 mph state highway, and the line was short.

It has been a while since I gave it a tune-up, perhaps I should do the plugs/wires/cap/rotor too...
 

·
Super Moderator
Joined
·
21,359 Posts
High CO can be from a rich mixture. Many folks removed the idle tamper proofing plug on the carburetor and cranked the screw out in order to smooth an idle or fix a stalling problem. The setting at the factory is usually correct, if the setting has to be changed it is usually because something else has changed and the added fuel compensates for the symptom. The wrong way to fix a problem. I used to have to reset many mixture screws back to where they were set before.
The air pump plumbing was to help the catalytic converter oxidize CO and HC. If the smog pump is seized, it could contribute to increased emissions and over work the cat.
The cat itself may also be in trouble at this age. A direct-fit would make an acceptable replacement if needed. I believe that only California does not allow direct-fit replacements, but maybe that doesn't apply to something this old.
In NY, the cat only has to be there (it doesn't even have to work) and there is no tailpipe gases test.
If you do a tune-up, the Champion plug type listed on your underhood label will give the best results.
 

·
Premium Member
Joined
·
20,074 Posts
Looking at the 88 of 220 starting to go up a little faster than it really should, even for a carb, so that can be both the indicaiton of the dirty air filter and making it run rich, to which a fresh tune-up may improve those numbers more than one would think. A weak spark (from lack of tune-up) generally increases the smog numbers as the rpm goes up and the spark starts weakening (or finding other routes to spark, shortest distance between two point thing), so they should only slightly go up at best. Just a comment and throught more than anything.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #8
Cat is original to vehicle, as far as I know (I've owned this thing since 1992 and don't recall ever changing it. Always passed with flying colors when the vac line to the computer was connected properly.

Last guy to touch the carb was a fellow at a local shop who used to work for a Chrysler dealer; last year when I took it in and he got assigned to it, he went into his attic and dug out all his old books (including the 2.2/2.5l drivability manual). He made a huge difference in how it runs, though he said couldn't figure out why the secondary wasn't opening up (didn't see a reason for it not to). I have to say though, it still runs better than it has in years.

I'm heading out to the local NAPA now for tune-up parts; considering all the ignition stuff is right in front and easy to get at, I should be able to knock that and the air filter out in about an hour flat.

Worst case, I'll call that shop again and see if that guy's available to look at it - he sure had a nice touch with it...
 

·
Premium Member
Joined
·
20,074 Posts
Should be OK with the filter and tune-up. Let us know how it goes. Thing about running good and not tuning them up, the drop-off of everything is so gradual one usually doesn't notice the slight difference in performance over time or know if the mileage is really dropping any.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #10
Yeah, I know what you mean - I drive this so rarely that I don't have as good a sense for how it's doing any more like I did when i drove it more. I certaqinly don't run enough gas through it to know what mileage it's getting.

That said, I had it out this week for the first time since last fall, and for what seemed like the first time in several years, I was able to get it wound out to about 35-38mph in first gear off the line. Even felt like something kicked in doing that, so maybe the secondary freed itself up a little.

If I can get this dealt with I'll get the headliner pulled - got covered in black dust (the old foam backing, I think) out on the highway with all the windows down, not fun. Time to order one of those kits online and redo it.
 

·
Premium Member
Joined
·
20,074 Posts
Yeah, I have replaced a few of those headliners in the past, nothing works on trying to repair even though someone did make wooden dowel makeshift bows to run side to side. Doesn't fix the problem, but it does get it off the top of your head. I simply take the panel out and take it down to a local upholsterer and let them take care of it, worth it to know it will last longer than original.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #12
Yeah, I know it's dicey getting a DIY redo to hold well, but I ran across a guy on a Jeep board that actually fiberglassed his board before applying the spray adhesive, and it seemed to work pretty well - sounded like by 'glassing it, he gave the porous board a non-porous surface that the glue held better to. I'm going to try a couple thin coats of either gloss-finish spray paint or polyurethane and see if I can't get a similar effect.

Figure it's worth a try.
 

·
Premium Member
Joined
·
20,074 Posts
As long as the foam rubber, which is powdered from the heat, isn't still on the material it should work.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #14
Ok, did the plugs/wires/cap/rotor/air filter yesterday (air filter was definitely in need of changing), and ran it back through today:

Not only did it fail, it got worse:

Standing Idle:
HC ppm 58 (220 allowed) was 28
CO% 1.83 (1.20 allowed) was 0.53
CO2% 13.6 was 14.3
O2% 0.7 was 0.9

High Idle
HC ppm 118 (220 allowed) was 88
CO% 5.67 (1.20 allowed) was 4.65
CO2% 11.6 was 12.1
O2% 0.2 was 0.2

Now I'm failing CO on both tests. I only took a shot at this myself this time because I had taken a few days off to enjoy my pool and relax, and noticed that it was due. I've made an appointment at the shop I've taken it to the last couple times (the one I mentioned earlier in the thread) to deal with that and do a (long-overdue) coolant change.

I will post up when I know what the diagnosis turns out to be.
 

·
Premium Member
Joined
·
20,074 Posts
Have to admit, this is the first time I have seen this. Hindsight is a wonderful thing, but I wonder if it would have made a difference if the battery was disconnected to set the computer to factory pre-sets? If things like the air filter was as dirty as it was and worn components operating acceptably, not sure why it would have gotten worse unless the engine just wasn't warmed up enough to readjust itself before retesting.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #16
Is the "disconnnect the computer from the battery" trick even applicable to this old thing? I didn't try that, but with this thing it wouldn't have occurred to me to think the spark computer would even be smart enough for that sort of thing.

if anything, maybe it was too warm - it got a good 30-minute drive to the inspection station, and with the coolant being rather past its shelf life I wonder if perhaps I was running a bit hotter than normal.

At any rate, I'll be dropping it off with the shop late next week, and he's going to see what happens if he runs the test when it's cooler - said that may lower the numbers a bit. Either way, he's going to address the CO issue and replace the coolant for me.
 

·
Super Moderator
Joined
·
31,983 Posts
"CO occurs when a car is too rich. Common causes include a failed O2 sensor, a failed MAF sensor, a failed coolant temperature sensor, a fuel pressure regulator leaking fuel into the vacuum port, too little ignition timing, a failed catalytic converter, or a failed secondary air system."

"Ignition timing that is too far retarded may result in high HC or CO."

"When you fail because your CO or carbon monoxide is too high, that means the fuel and air ratio is way off and there is evidence of incomplete combustion or burning of the air/fuel mixture. Most of the common causes relate to the carburetor or the fuel delivery system. A CO failure will always be rooted in the carburetor or fuel injection system. CO failures are not fixed with spark plugs.
If there is too much fuel and not enough air, a CO failure is usually seen. When there is too much air and not enough fuel, a HC failure is generally seen."

"Here's some common causes for the production of these three pollutants.
CO Failures (vehicles with carbs)
1. Engine not at operating temperature. Example, engine/cat cooled off while waiting in test line or has a stuck open or missing t-stat.
2. Bad or misadjusted float level.
3. Plugged air bleed passages or misadjusted main metering system, leaking fuel passages or gaskets.
4. Maladjusted idle air/fuel mixture screws.
5. Ruptured or sticking canister purge valve.
6. PCV plugged or drawing in fuel contaminated oil vapors.
7. Malfunctioning mixture control device.
8. Malfunctioning computer inputs. Example: O2 sensor defective, reading lean all the time. MAP sensor vacuum hose being clogged or broken (reading a heavy load all the time). Coolant temperature sensor having high resistance or open circuit (reading "cold engine" all the time). Throttle position sensor stuck or open ground, (reading wide open throttle).
9. Contaminated, restricted or bad catalytic converter."
 

·
Registered
Joined
·
182 Posts
Discussion Starter #18
Well, just picked up the car up from the shop (I let them take their time since it's not a daily driver), and have a shiny new inspection sticker.

I ended up having to get the air pump replaced (and the long-missing belt for it as well), and the tube from the pump to the catalytic converter restored (rotted away years ago, was surprised it turned out to be easy to locate). Had a coolant flush done as well, since it'd literally been years since I'd last had that done.

So, without further ado, the final (passing) numbers:

Standing Idle Test:
HC ppm: 25 (standard = 220)
CO% 0.00 (standard = 1.2)
CO2% 10.3
O2% 6.1

High Idle Test:
HC ppm: 27 (standard = 220)
CO% 0.00 (standard = 1.2)
CO2% 10.4
O2% 5.3

Cat was not touched, and I don't recall ever having changed it (may well be original). In 21 years of ownership, I think this is the first time it's not only had a working air pump but actually needed it to pass emissions. The guy who worked it over last year said the feedback systems wouldn't work quite right without the air pump functioning; I am looking forward to getting out for a short highway run to see how she runs now...
 
1 - 18 of 18 Posts
Top