Allpar Forums banner
1 - 9 of 9 Posts

·
370,000 miles
Joined
·
1,424 Posts
Discussion Starter · #1 ·
Apologies in advance for this long rant.

I was overall very pleased with Uconnect on my 2015 Charger and 2017 300C. The only complaints I had were with the frequent Sirius weather alerts that would pop up on the screen and I had to manually clear. In my 2021 Pacifica, they seem to have listened to customers and gotten rid of that problem – I was happy about that. But in other ways, Uconnect has gotten worse.

I never want to tune in radio stations. The only audio source I ever want to use is my phone through bluetooth. I only want to listen to podcasts. This worked very well on my previous cars, but not with this car. About 80% of the times I start the car it sources FM radio, even though I was listening to a podcast when I shut the car off before. And it always is on FM 107.9, which is nothing but static where I live, and it blasts this static way too loud (as if it doesn’t know how to normalize the volume across audio sources, or maybe it just doesn’t have memory of my volume setting anyway). I’ve tried to address this by setting the FM to a local station so I don’t get blasted by static, but it always goes back to 107.9. I feel that I should be able to configure Uconnect to allow only a subset of possible audio sources (then I would remove all sources except bluetooth), but the software doesn’t allow that configuration option.

In the 20% of the starts that it remembers I was using bluetooth audio, it doesn’t remember that I had the podcast paused. It seems to want to default to play state. Now this could be due to some update to my podcast app (I use Castbox), but this never happened with my other cars. And since Uconnect doesn’t seem to be doing a good job of remembering my previous settings in other areas (volume, audio source, FM station), I think it’s most likely that this is also a Uconnect issue.

Another issue is that many times it defaults to the driver profile selection screen. If the driver has been selected using the buttons on the door, then it shouldn’t display this screen. And the screen is very tenacious – I manually get out of it and move to the media screen, but when I come out of reverse and the backup camera goes off, there the driver profile selection screen is again. Stuff like this drives me nuts.

I never had these problems with my Charger or my 300C. It always came back to bluetooth audio and the media screen when I started my car, and it remembered the play/paused state that existed before shutdown. I will say that I had to get the radio replaced in my 2021 Pacifica under warranty, so maybe there was some kind of issue in the replacement that is causing this trouble, but I had at least some of these problems before that.

Does this sound like something may be faulty with my particular Uconnect hardware, or is this just the way it works now?
 

·
Super Moderator
1966 Crown Coupe, 2016 200 S AWD, 1962 Lark Daytona V8.
Joined
·
23,672 Posts
There have been a number of software updates that have been released for the 2021 RU. Some may not apply due to options & build dates. The FOTA should take place automatically, if eligible:
Font Screenshot Number Document

Smile Rectangle Font Circle Writing

Font Number Rectangle Screenshot Circle

Font Number Screenshot Document

Font Number Screenshot Parallel

Font Number Screenshot Document Circle

Font Number Screenshot Document

Font Number Screenshot Document Rectangle

Font Number Screenshot Document

Font Number Screenshot Document
 

·
Move along, nothing to see here
Joined
·
2,744 Posts
I've got a '22 Pacifica and I haven't noticed any of the same problems you've mentioned. I did notice that going from my 5 year old Android phone to a new iPhone was a MASSIVE improvement in performance.

Only gripe I've had with it is over the air CarPlay (and Android Auto) are pretty vulnerable to external interference. There's certain areas where I drive through that it cuts out constantly and keeps disconnecting.
 

·
Registered
Joined
·
213 Posts
Issue with Uconnect 5 and the Android base rather than the QNIX base? Google is fairly anticompetitive and will make things out of the Google ecosystem not work well.
 

·
Premium Member
2002 Ram 2500 Quad Cab 4x4 with Cummins. 2021 Jeep Grand Cherokee L Altitude
Joined
·
4,966 Posts
I've not had any issues with Uconnect on my 21 WL. I don't know how to use all the features yet but I'm learning. I have mine on SXM 70s on 7 and it always stays on it when I restart the vehicle.
 

·
Official Mopar Reps
Joined
·
63 Posts
Apologies in advance for this long rant.

I was overall very pleased with Uconnect on my 2015 Charger and 2017 300C. The only complaints I had were with the frequent Sirius weather alerts that would pop up on the screen and I had to manually clear. In my 2021 Pacifica, they seem to have listened to customers and gotten rid of that problem – I was happy about that. But in other ways, Uconnect has gotten worse.

I never want to tune in radio stations. The only audio source I ever want to use is my phone through bluetooth. I only want to listen to podcasts. This worked very well on my previous cars, but not with this car. About 80% of the times I start the car it sources FM radio, even though I was listening to a podcast when I shut the car off before. And it always is on FM 107.9, which is nothing but static where I live, and it blasts this static way too loud (as if it doesn’t know how to normalize the volume across audio sources, or maybe it just doesn’t have memory of my volume setting anyway). I’ve tried to address this by setting the FM to a local station so I don’t get blasted by static, but it always goes back to 107.9. I feel that I should be able to configure Uconnect to allow only a subset of possible audio sources (then I would remove all sources except bluetooth), but the software doesn’t allow that configuration option.

In the 20% of the starts that it remembers I was using bluetooth audio, it doesn’t remember that I had the podcast paused. It seems to want to default to play state. Now this could be due to some update to my podcast app (I use Castbox), but this never happened with my other cars. And since Uconnect doesn’t seem to be doing a good job of remembering my previous settings in other areas (volume, audio source, FM station), I think it’s most likely that this is also a Uconnect issue.

Another issue is that many times it defaults to the driver profile selection screen. If the driver has been selected using the buttons on the door, then it shouldn’t display this screen. And the screen is very tenacious – I manually get out of it and move to the media screen, but when I come out of reverse and the backup camera goes off, there the driver profile selection screen is again. Stuff like this drives me nuts.

I never had these problems with my Charger or my 300C. It always came back to bluetooth audio and the media screen when I started my car, and it remembered the play/paused state that existed before shutdown. I will say that I had to get the radio replaced in my 2021 Pacifica under warranty, so maybe there was some kind of issue in the replacement that is causing this trouble, but I had at least some of these problems before that.

Does this sound like something may be faulty with my particular Uconnect hardware, or is this just the way it works now?
Hi somber,
Sorry to hear you're experiencing concerns with your UConnect system! Feel free to send us a PM with your VIN for further assistance.

Sarah
Mopar Cares
 
1 - 9 of 9 Posts
Top