Allpar Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,872 Posts
Discussion Starter #1
I have a 2003 Sebring Coupe (yeah a Mitsu I know..) and I have a popping bouncing noise that developed recently when turning right, steering is tight, I've ran my full size spare to rule out the tire... Changed the brake rotor, pads and guide pins.. Inspected everything.. All looks ok. What the heck is wrong?'
 

·
Super Moderator
Joined
·
21,357 Posts
Does it vary with acceleration or the speed and sharpness of the turn? Possibly the outer axle joint has ingested water? The boot doesn't have to split as I have seen loose boot clamps let dirt and water in without letting much grease out.
 

·
Super Moderator
Joined
·
31,983 Posts
Probably the CV joint.
 

·
Registered
Joined
·
8,042 Posts
I'd just replace the entire axle half-shaft if I were you. Cheaper and easier than trying to change out a cv joint. And you'll need to get an alignment afterward. I learned that one the hard way.
 

·
Registered
Joined
·
1,872 Posts
Discussion Starter #5
Well the dealer said everything looked ok... Im doubting it.
 

·
Super Moderator
Joined
·
31,983 Posts
Tell them to put it in writing, and also that they'll come get you for free wherever you are, when the axle takes a dump.

Popping noise is NOT OK. Maybe try another dealer.
 

·
Super Moderator
Joined
·
21,357 Posts
Were you able to demonstrate the noise and did the technician get to witness it?
If you already paid the repair order 'price of admission' (diagnostic charge), I would not let them give up that easily. There is an issue.
Going to another dealer may be a 2nd diagnostic charge.
 

·
Registered
Joined
·
1,872 Posts
Discussion Starter #8
It was part of the "courtesy multi-point inspection". They also said my very noisy struts were ok too.. I'm thinking about demonstrating it for them... I also need to have my timing belt and water pump changed too. I wasn't persistent with the problem as the dealer is 35 miles away... And the dealer 3 miles away is soooo crooked...
 

·
Registered
Joined
·
1,872 Posts
Discussion Starter #10
I'm thinking it's the strut bearing or cv. Anyway I have all the parts or have them on order to straighten out the front end prrmoblems. New lh cv new struts springs and mounts new sway bar end links... I do know the problem isn't ball joints and they pass with flying colors.
 
1 - 10 of 10 Posts
Top