Allpar Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Up until this week I had no issues with my rear hatch but now the outside release does not function, it works fine with the key door opens and closes smooth. also when using the key it opens all locks like its supposed to only the outside switch seems to be affected does anyone know if this switch is on same circuit as power door locks ?
 

·
Registered
Joined
·
1,087 Posts
It sounds like the touch sensitive switch in the rear handle has failed. You can take off the inner plastic panel and unplug the switch. Jumper the switch wire and see if the latch solenoid operates. If it does then you have a bad switch. If it doesn't then you'll need to troubleshoot further.
 

·
Registered
Joined
·
148 Posts
Hi Jim,

Ran into a similar situation with my recently "inherited" 2005 (I have 2 PT's now). My problem was that the rear hatch opened by itself, causing the "dinging" alarm and dash light. One night when I was in the garage I could hear the switch "clinking" and opening the rear hatch lock on it's own. Spooky.

I opened the inner cover and disconnected the harness wire leading to just the electric actuator. I use the key without a problem to open the hatch and wouldn't you know even the 4 door locks still pop open when I activate the rear hatch by key.

I've learned to live with these Chrysler malfunctions after 3 years owning a 2001 PT. (sigh and Sic)

I would further suggest to George's reply that you apply battery voltage to the actuator to hear if that is also working, if it's dead that's the fault. Personally I had no idea this/these 2005 cars(trucks) had a touch sensitive switch,, just more garbage to go wrong as I see it. My 2001 has the KISS feature and uses a key only.

Since this 2005 car has only 50K mileage I'm truly hoping It's not the maintenance buttache the 2001 has been in the last 3 years.
to wit:

[SIZE=18pt]Repairs to PT 2001 Cruiser[/SIZE]

[SIZE=18pt]Rack and Pinion-was supplied by seller to consummate us buying the car.[/SIZE]

[SIZE=18pt]Replaced drs side MacPherson strut-complete w spring.[/SIZE]
[SIZE=18pt]Replaced connector at radiator fan.[/SIZE]
[SIZE=18pt]4 tires replaced.[/SIZE]
[SIZE=18pt]Added new wheel cover/hubcap[/SIZE]
[SIZE=18pt]Replaced R Frt rotor during 1st caliper pad replacement @ 150K[/SIZE]
[SIZE=18pt]Replaced starter and solenoid.[/SIZE]
[SIZE=18pt]Replaced battery.[/SIZE]
[SIZE=18pt]Replaced aftermarket taillights with OEM units.(Owned by kids)[/SIZE]
[SIZE=18pt]Replaced radiator. (Platic parts failed)[/SIZE]
[SIZE=18pt]Replaced Body Computer thru Chrysler in Pompano. ($$Ouch$$)[/SIZE]
[SIZE=18pt] “ battery lead wires, both.[/SIZE]
[SIZE=18pt]Replaced alternator.[/SIZE]
[SIZE=18pt]Replaced battery.[/SIZE]
[SIZE=18pt]Replaced frt caliper pads at 170,000. (20K maybe the Mrs is racing??)[/SIZE]
[SIZE=18pt]Replaced 4 tires.[/SIZE]
[SIZE=18pt]Replace front LCA ball joints and bushings 170K (No fun folks)[/SIZE]
[SIZE=18pt]Repair pass side shaft boot, inner[/SIZE]
[SIZE=18pt]Replace o2 sensor at exhaust manifold. (used NLT parts)[/SIZE]
[SIZE=18pt](Obtained 3 defective o2 units from Advanced Auto.)[/SIZE]
[SIZE=18pt]Replace front rt motor mount.[/SIZE]
[SIZE=18pt]Replace o2 sensor at exhaust manifold. (used NLT parts)[/SIZE]
[SIZE=18pt]Replaced frt rt motor mount with new.[/SIZE]
[SIZE=18pt]Installed window wind deflectors. (It rains heavy here!!)[/SIZE]
[SIZE=18pt]Rec’d P-0135 o2 Code again-Sensor1 Bank 1 front sensor. (used Bosch Premium this time)[/SIZE]
[SIZE=18pt]Rec’d P-0135 Code again-Sensor1 Bank 1 front sensor. (used Denso this time)[/SIZE]
[SIZE=18pt]Replaced pass side half shaft 4-13[/SIZE]
[SIZE=18pt]Replaced drs side half shaft 5-13[/SIZE]
[SIZE=18pt]Replaced power steering pump with high pressure hose 6-13 (have write up)[/SIZE]
 

·
Registered
Joined
·
54 Posts
Discussion Starter #4
well took it apart switch and solenoid both work but cleaning contacts on connector solved problem at least for now am looking for a replacement switch now though since it seems to be a discontinued part. anyone who has one and needs part # it's 4671966AA at least on my 2005 it's not just the switch it's integrated with the entire Chrysler emblem.


As far as the front pads go on this car I have fount the front calipers stick as they begin to fail wearing out a new set of pads in record time.
As far as the plug on radiator fan goes I did away with the plug an hard wired mine after I was told the fan was bad I replaced it and about 3 months later it started over heating again, I crawled under and shock plug and it worked took it to shop was told I had a bad fan went home and hard wired and it has not given me any more trouble that's about 4 years ago.
 
1 - 4 of 4 Posts
Top