Allpar Forums banner

Sebring '02 heater blower not working at any speed

7525 Views 6 Replies 3 Participants Last post by  Stratuscaster
Hi, Sebring '02, convertible back again with another problem. Heater/AC blower stopped working all together. Blower speed select switch does not work at any speed. 30 amp blower fuse good. Blower resister failed a few years ago, but would work on high (4) back then. Problem this time is no blower speed functions at all. Lights on control head work, rear defroster light works. Removed control head and sprayed contact cleaner on speed switch areas that were visible, but no improvement. Any idea what maybe causing this? Is there something else in the blower speed circuit that could cause this problem?
1 - 3 of 7 Posts
Does anyone have a wiring diagram so I can try direct wiring blower? Thanks.
:) Ok, problem solved. He's what I found. Grounded black wire on blower connector with key in "run" and it spun up with no problem, so blower is good. Tracing wires back from blower, I grounded wires on the resistor block connector, key in "run", one at a time with high tech jumper wire (paper clip), no blower function on any wire except the wire going directly to blower motor. Since this bypassed fan speed control head, I assumed the only thing left in the circuit was the resister block. Pulled resister block out and measured each terminal with ohm meter. No continuity between blower motor terminal and any other terminal. So things were pointing towards it being the resistor block. Picked up a unit at local parts house that offered lifetime warranty on part made by BWD (non OEM). Plugged it in with block hanging out of blower for just a few seconds and blower worked on all speeds. Next, per instructions with new block, I had to cut the blower housing a bit to accommodate new block. Buttoned up everything and it works fine. One note, In reading about resistor block problems and having had one fail a few years ago, they all centered on losing speeds 1,2,3 and 4 working. Same as my earlier failure. I've now learned from latest failure that position 4 (High) is also effected by resister block and is not a true hard bypass. Just wanted to share that with everyone in case someone else has this problem. Thanks for everyone’s help, it's greatly appreciated. Great website with great contributors.
See less See more
1 - 3 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.