Allpar Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
324 Posts
Discussion Starter #1
Hello all. working on my sisters 01 PT auto NON turbo.

She has been having issues with power steering. firstly a loud groaning noise and no power assist. diagnosed this as a faulty pump. it ran out of fluid, she never checked it and ran it that way some time and that appears to have killed the pump. the orginal leak seemed to be comming from the pump area.

i changed the pump for a new one, filled and bleed the system. and everything was fine and quiet for a few days. then it ran low on fluid again, she wasnt keep an eye on it. noise came back topped it off and bleed noise still there i think the 2nd pump is now damage too.

however what is wiered the top of the reservior was all wet. cleaned it off let it run and watched. fluid came out the cap area. slow however but you could watch it happen. at the time it was not overfull. but was and is rather foamy.

question, to me i wouldnt think there is any pressure in that reservior to force the fluid to leak out. being it is all low pressure lines back feeding into the cup and out to the pump. could somthing be causing an increas of pressure to force fluid out? is it just a bad cap causing a leak? last time i replaced the pump i took the res off and cleaned it and blew it out. it did not leak itself, though i did not test the cap.

from what i have read online, people keep referencing some kind of filter that gets plugged. i have not seen this and dont know where to locate it. is it in the res? perhaps its not on the 01 as from what i have found in my research the part number for the power steering res for an 01 is differnt than 02+ so perhaps that filter was a revision?

the rack looks dry, the high pressure line and cooler are bone dry. i feel that i will have to replace the pump again, but dont want the problem to re occur.

what advice can you offer a PT newb?
 

·
Premium Member
Joined
·
4,969 Posts
01 still uses power steering fluid. Not ATF+4.
 

·
Registered
Joined
·
324 Posts
Discussion Starter #5
but the thinking is to replace the reservior? try that first then maybe have to change pump? naturally flushing is included in that. and i will change to ATF4 what is in there now is power steering fluid. and that was in there before i changed the pump so thats what i put back.
 

·
Registered
Joined
·
324 Posts
Discussion Starter #6
Update, made the swap. Been in there a week now. Continues to run normally, so I think wet can call this solved. Thanks for the help.
 
1 - 6 of 6 Posts
Top