Allpar Forums banner
1 - 2 of 24 Posts

· Registered
Joined
·
765 Posts
I think you need a new rad. At the very least you need it flushed.
 

· Registered
Joined
·
765 Posts
That is what so frustrating. I can operate the car at 80 mph (interstate) on an 80F day and it actually runs cooler than it does at 30 mph. The heater is a furnace especially out of the dash ducting in 30 degree F weather. The radiator fan is on all the time (ignition) which I do not like at all.

I was thinking that I could somehow "cheat" and bypass the transmission cooling through an aftermarket trans cooler and relieve the heat load on the radiator. But how much heat does the transmission develop? I would hate to live on beans and catsup for a month and find out the radiator was not the problem. Transmission coolers are a fraction of the cost, but would one help? Agh!
I would believe that a healthy cooling system would be opposite. Cooler a slower speeds.
Is it possible that the air flow through the heat exchanger and rad is somehow restricted or misdirected? Make sure that none of the rubber and plastic flaps that go around the front of the radiator support are missing.

If the dealer flushed the car years ago this may not be a new symptom/complaint for this car.

Does anyone here know if there are different water pumps for different years? Some with reverse flow possibly?
 
1 - 2 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top