Allpar Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
89 DAYTONA Shelby 2.5 none intercooled turbo. car set for about 14 years got it running a few weeks ago and the turbo seams to be stuck in hi boost.shows 3 psi of boost at idle and you can hear it spooling up..At 3500 RPM's she is around 10 psi of boost. I think the wastgate is stuck but not sure.any ideals or anyone have this problem befor?
 

·
Registered
Joined
·
646 Posts
I know the gauge is problematic. See what you have for boost with the engine off. If the gauge doesn't move between engine off and idle, then you may have a SERIOUS exhaust blockage, or just a vacuum hose off. If you show boost, but not vacuum, I'm back to exhaust blockage. It would have to be serious, and you wouldn't have any power (even at 10 psi boost).

Mike
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
When you shut the car off it goes back to zero.and when its cranking be for the start it shows vacuum.And she has power to spare.She will smoke the tires at 30 mph like nothing.I even throw anothere boost gauge on it. thinking the gauge was off.I'm going to buy anothere wastgate to see if that helps.Mind you I dont mind the power at all it sort of nice pulling away from anything I wont to .but I dont wont to blow the moter becouse of over boosting it .
 

·
Super Moderator
Joined
·
31,989 Posts
I think Mike has it right, if you get zero with engine off, vacuum while cranking, and then a real 3 psi boost at idle, as evidenced by spooling and extra power at takeoff, you probably have a clogged catalytic converter or muffler. It's creating enough backpressure to make the turbo spool up.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Ok bad cat.Cool that gives me a reson to run 3' pipes and put my flowmaster on it..Thanks guys.
 
1 - 6 of 6 Posts
Top