Allpar Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
704 Posts
Discussion Starter · #1 ·
Hey guys,

I´ll recieve my new TCM and also a new (Mopar) Solenoid Block next week.

One thing that i wont get yet.....in which way are the in / output speed sensors responsible for shift quality etc?

I have a pretty bad shift quality and delayed shifting up to 4th, you almost can hear the problem comming from the solenoids (cause of a missing sound shield). That´s why i replace it.

But how do they work together?
And, if i replace the TCM & Solenoid Block, should i also replace both sensors? Or how can i figure out if they´re working right?

Thank you
Kevin
 

·
Registered
Joined
·
704 Posts
Discussion Starter · #3 ·
OK, i´ll clean them out!

Will i loose any fluid or just a few drops?

Thanks,

Kevin
 

·
Registered
Joined
·
704 Posts
Discussion Starter · #7 ·
If you don't have any fault codes for input (turbine) or output speed sensors (TCM codes 56 and 57), I would leave them be.
The magnetic tip does collect 'fuzz' and this can trigger fault codes and limp-in as the TCM gets a fuzzy rpm reading. It needs to see a sharp square waveform. Clean the tips and reinstall. I hope that the upgraded software in the replacement TCM cures the problems.
One sensor has course threads, the other has fine threads so they can only go back in the correct hole.
Well thank you!

New TCM left LA at sunday, so i should recieve it this week.

I hope it works better then now, feels like the solenoid block is working too "slow", so there are some harder up and downshifts.
If i feel any difference with the new TCM, i´ll clean the in / output speed sensors and also replace the solenoid block, arround 100 USD, new MoPar´t, if it doesn´t work and the tranny is really ready for a rebuild, my minivan will recieve the block as a nice little gift :)
 
1 - 4 of 4 Posts
Top